Exceeded allowed activations

Due to a Windows 11 issue I had to reinstall Windows on my main PC and therefore SU2023 Pro/Studio as well. I now get the tiresome ‘Exceeded allowed activations’ notification and cannot log in to Sketchup. I’ve logged out of my Trimble accounts and logged out of the local Sketchup login. I’ve also deleted the login.session.dat.
Strangely I can still run SU2023 on my laptop as normal, and have logged out of it again just to be sure. But nothing helps. Does anyone know if there is a Registry hook somewhere from the Windows re-installation that might be fooling this PC?

Go to Trimble | Account Management, and login.

Click on View included Application then Manage Devices

image

In a popup, Deauthorize All.

image

(This will Deauthorize all your devices, including your Laptop as well)
Restart Sketchup then try to login. (perhaps log out, Restart Sketchup and login)

Ha, yes of course! I forgot about the Manage Devices bit! I’m so used to installing updates and running tests year-on-year.
Many thanks - that worked after 5 log-outs and log-ins in various places. Good call.

Great, clear video.

Unfortunately, I’m stuck in a loop. After I deauthorize all and close out of the Trimble window, when I restart Sketchup pro, the same “You have exceeded your allowed activations” window pops up.

I’ve rebooted the MBP after one cycle.

I reinstalled Sketchup and rebooted.

This really sucks. I just bought Profile Builder 4 (after Justin’s presentation) and I wanted to install it and try it out. And another thing…Trimble is asking me to sign in too much. Can they not do some other method of validating my subscription?

Anyways…it is now 4:14 am and I can’t install the $149 extension that I just bought.
Not one bit happy about any of this.

And then I tried the link to “Need more help” and it takes me to a screen that says “You are not authorized to access this page.”
NOT
HELPFUL
AT
ALL

The first thing you need to do before doing anything, which is not shown in the video, is to sign out and close SketchUp and Layout. Do this by clicking the little avatar in the top right corner of the warning window. Sign out and close everything.

If that does not work, submit a support ticket here - https://help.sketchup.com/en/contact-support/technical-question/form

Hello, yes I turned off the transfer and restarted the computer. I already sent the ticket. Thank you

I finally saw someone else’s answer on the forum. Where it indicated that you had to go to “View included Application”, then “Manage Devices” and then “Desauthorize All”. I restarted the program and now it works.

yep…did all that.

Deauthorize all didn’t change things.

I gave it time and tried again 6 hours later and everything worked. I can open SU now…reinstalling it as part of the TS steps was a mistake. My templates are gone.

If your templates were in the correct folder and you didn’t delete them they should still be there even if you removed and reinstalled SketchUp. Removing the application should not remove folders templates, extensions, etc.

1 Like