Why is the grey area not selectable

I’m a noob in SketchUp so please bear with me. I used the line tool to make an area but the same method that worked for me on the other areas I made is not working for this specific area. This specific area has grey lines while the others (selectable areas) have black lines. Also this areas body is filled with a grey color but the other (selectable areas) body is filled with white color. This grey area cannot be selected nor can I select the grey border lines even to delete it. Why is this area not responsive? Where did I go wrong? I uploaded an image below to show my problem better. Any help is appreciated. Thanks in advance.

Draw a line over raw geometry (inside the group)

Learn the basics of SketchUp at https://learn.sketchup.com/

I already tried that but its not working. Its like creating a new area on top of the grey area. Result below.

Would be helpful if you could share the model for further inspection to determin what is the problem.

It is possible to have created another face outside the group.


1 Like

The model is attached below.

temp sketch.skp (80.9 KB)

i checked my tags and there is only one group.

Not realy, you have groups within other groups.

how do you add the outliner tab?

Window > Default Tray > Outliner

So first question does every new area made with lines create a new group?
Second I deleted the extra group and now the grey unelectable area is gone and now I can select the specific line I want to select but I can’t select the area bounded by those lines .

When i opened your model i did not see any grey surfaces.
Did notice the amount of groups inside groups which are inside groups of a group.
(as @mihai.s showed :wink: )

I guess the ‘grey’ shape (i did not see) is an opening for stairs in the ‘floorsurface’?
If so i’ve noticed the ‘grey’ area was floating (circa 1,76m) above the bigger surface.
So the program showed one color/face (first opening), on top of another color/face (copy of first opening?), on top of another color/face (floor surface), which could result in the ‘z fighting’ issue.

I managed to delete the ‘second opening’, moved the ‘first opening’ on top of the ‘floorsurface’, which resulting in the ability to create the hole in the floor and removed the z-fighting.
faces on top of faces on top of faces

Hope this helps solve your problem :crossed_fingers:

Found your ‘grey’ surface.
The grey surface is a surface outside the group you were trying to edit, so yes, you could not select or edit it since it was not active.

Try not to create groups of already excisting groups, and try to rename them groups so you can find/select/edit specific groups more easily.
grey is a surface outside the current group you are editing

which make me wonder again does every new area made with lines create a new group? Because I didn’t explicitly create a new group.

Does your building have these dimensions?


I guess it’s a dutch house, we are known to be very tall :wink:


This model is just a rough sketch I will metrically construct a new model later on.

As far as i know it does not create new groups everytime you create a closed area or something.
No clue if one could turn this feature on/off somewhere, at least i haven’t found it yet :thinking:

Used tnt to explode the groups, recreate the groups and changed their name, should make future editing much more easy :wink:
fast fix groups

No. Groups are not automatically created. You must have created them.

I was going to apply your advice but even though I grouped the middle rooms and renamed them successfully I couldn’t assign a group to the right bordered area because it is still unselectable. 3d file attached below.

temp sketch 2.skp (75.1 KB)