Unable to select edge

I have created a simple one room building and added a ground layer around it but can only select three edges of this layer. If I try to draw a line along the other edge it shows ‘intersection with hidden section’ when I hover over the end. Edit / Unhide / All makes no difference. Any ideas on what might be causing this?

That message is letting you know that you are interacting with invisible geometry. Check to see if you have any layers turned off, or if you have any hidden geometry (View - Hidden Geometry). Turn the hidden geometry visible and you should be good.

On a side note, this is an indicator that you, possibly, are not using containers. To get the most out of SketchUp, you should create groups around geometry once you have completed it to prevent it from interacting with other loose geometry.

1 Like

If I had to guess, which I must, because you haven’t shared the model file…
I’d say you’re not making Groups and Components of logical parts of the building as you go along.
That, and you’re using SketchUp’s layer system improperly.

Here’s help with with those issues.


Thank you @TheOnlyAaron and @geo for your swift replies. I have tried viewing hidden geometry without it showing anything. I am going to start again from scratch and make more use of groups/components. As a newcomer to Sketchup it will be good practice.

2 Likes

Geo, as a learning exercise for me could you take a look at my problem model and advise what I’ve done wrong. Probably lots! It might be useful for the future. Dropbox link https://www.dropbox.com/s/gptl723bpwlqos4/SummerHouse_new.skp?dl=0

As Geo hasn’t yet had time to respond, I’ve had a quick look, and I agree it is not immediately clear how you have managed to make that edge (the nearer edge of the ground) invisible and unselectable.

When I try to draw a line along the front edge, I get an inference point on the corner of the ‘lawn’ saying there is an intersection with a hidden section. Looks as though you have accidentally or deliberately introduced a section plane. It’s possible to create a section plane by mistake via an accidentally triggered keyboard shortcut - I’ve done it by accident myself, though I can’t offhand remember what the shortcut is, or whether one is set by default.

There’s also an End Point inference just a short distance in front of that corner. So it looks as if you have managed to introduce a section plane, hidden it, and obscured part of the existing geometry in front of it, including your missing edge.

Use View/Section Planes to reveal this section plane, and R-click/Erase it. Then the line becomes visible and selectable. And incidentally, you also reveal some stray lines in front of the lawn. Erase them too, as they don’t appear to signify anything obviously meaningful.

There’s one other repeated ‘no-no’ in your model. You have assigned layers not only to groups and components (good practice) but also to native geometry - edges and faces (EXTREMELY bad practice). Go back to each group or component in turn, open it for editing, Select All in the group or component to select all its raw geometry and/or sub-groups, and assign Layer0 to it. ALWAYS, ALWAYS, draw raw geometry on Layer0, and (almost) NEVER make any other layer the default layer to draw on - leave the Layer0 radio button checked in the Layers window all the time.

Not a lot else obviously wrong with the model, though a few other things could be improved.

Try using Components more, instead of Groups, and give them meaningful names. It isn’t particularly helpful when viewing the structure of the model in Outliner to see a Group, consisting of many other Groups - none named. You can name components, and MUST give each component definition a unique name. (You MAY also give each individual component instance a name, but that’s optional, and they do not all have to be different.)

One of the other advantages of Components is that if you accidentally delete an instance in the model, you can recover it from the Components window, whereas a deleted group is harder or impossible to recover except from a previously saved or backup copy. Groups are internally only Components with some of their attributes concealed. Yet another advantage, which bears fruit in larger models, is that repeated copies of a component (except for very simple components) take up less file space than repeated groups.

And your roses showing through the windows are tiled all over the inside face of the back wall. Better, perhaps, to limit them to two smaller window areas on their own faces?

I hope that’s helpful, and understandable. If not, please post again and I’ll try to clarify further.

1 Like

Thanks John for your detailed and informative reply. I have done as you suggested and removed the section plane and additional lines. I have also moved the ground, fencing, doors, panels and wall layers to layer0 leaving just the roofing, donkey ( Pedro ) and westies layers. I take it this what you meant. I was following the tutorials on harwoodpodcast.com regarding the layers but may have misinterpreted their guidance. It was also there that I picked up making different layers active before adding things. Would it be correct to make things like the ground into a component? Thanks again, Tony

It would be fine to make the ground into a component.

But why did you return the groups for the other things to Layer0? I only want you to assign Layer0 to ALL the raw geometry IN those groups, not to assign Layer0 to the groups themselves.

Just to make sure I understand what you have done, could you upload a link to your revised file here again, please?

PS. It’s also worth searching this forum for ‘layers’ - there are lots of examples of people (especially if they have used AutoCad or PhotoShop before trying SU) misunderstanding the use of ‘Layers’ in Sketchup, which deals with them very differently.

If you do that, you will also find links to tutorials about how to use layers in SU, and what they DON’T do, which is separate geometry. They ONLY control visibility when turned on or off. Here’s one such link:
http://help.sketchup.com/en/article/3000122

SU uses components and groups to separate different ‘parts’ of the geometry from connecting to each other.

Hi again John. I just deleted the layers and assigned the contents to layer0. The previous link should work for the revised model.

Thanks. Just downloading the revised model now - will take a few mins. I have a fast connection, but it seems a bit congested at the moment, and is indicating around 7 mins for just 16MB.

As I thought from your description, you haven’t moved the faces and edges to Layer0, just the group(s).

Go back to your original, leave the layers as they are, and do what I suggested before - open a group, select all (to get all the raw geometry in the group, as well as any subgroups) then set THAT to Layer0. Then close the group.

And the groups don’t make much sense to me, now I look at them more closely.

Make a component each, out of at least the Roof assembly, the Front Wall, each Side Wall, Back Wall and Outside wall elements. That’s pretty easy - just open the main Group for editing, and use a left to right window selection to grab the elements in each.

But you have a bit of a muddle in the outside wall. Most but not all of it is in a Group of its own, but there is stray geometry (the pillar at the R hand end) that is only part of the containing group in which it is nested, not the outside wall group you have made inside the rest of the back wall.

And the roof should be re-configured to use Components for each separate part of it. You have made groups out of the rafter frames, and I suspect copied them along. They’d be better as components, each frame made out of separate components for each piece of timber. But the barge boards at the end are just loose geometry inside the roof Group.

If you were then to assign each wall to a layer, you could turn the layers off one by one to see ‘inside’ the building from any direction.

I’d turn off the Endpoints setting in Styles - though it usefully shows that that the top edges of the front and back walls have extra line segments in and around them. It looks to me as if you ‘caught’ some of the loose geometry from the bottom of a rafter, and included it in the top of the wall.

Anyway, best of luck with a further small redraw - it should only take ten to fifteen minutes to fix as I have suggested, and it will work much better.

Thanks again John. When deleting a layer, you get three option - move contents to default layer, move contents to active layer and delete contents. Does the first option not do what you are asking?

The first option, or the second, will both have the same effect if the default Layer0 is (as it normally should be) the Active layer - with its radio button checked in the Layers panel.

Reassigning a Group to Layer0 is not guaranteed to reassign all its contents to Layer0. And conversely, once you have the edges and faces on Layer0, assigning the containing group or component to another layer will NOT change its contents to that layer. (Except when you Explode the group or component, when, bizarrely, it does, I seem to remember).

Hi John. I have started this model again and wondered if you could take a quick look to see if I’m on the right lines. I have not grouped the individual walls as I don’t need to set them as layers.
Dropbox link: https://www.dropbox.com/s/nxcyhr8yf6nlgf9/sh.skp?dl=0

Thanks, Tony

Just had time for a quick look. I think this is off to a much better start - great.

You’ve use components in the roof, as I recommended, and that looks good.

Are the front and rear rafters the same as each other? If so, you could reduce the component count by replacing one by the other - mirrored or flipped to get them sloping the other way.

And the left and right doorframe components are probably the same as each other - if mirrored, at least.

I frequently use TIG’s Mirror plugin - worth downloading and installing (free) from the Sketchucation Plugin Store - see www.sketchucation.com/pluginstore. It’s easiest to download first the Sketchucation plugin manager, then find and install other plugins from that.

However, you can get the same effect by using the native Flip Along … tool (R-click on a selected component to select it) preceded or followed by a move.

And optionally, you could R-click on the sloping rafters and Change Axes, to get the blue bounding box to line up with with the long edges. Not critical, just better practice, especially if you want to list component dimensions using something like CutList.

Although you don’t need, you say, to assign layer visibility to individual walls, I still think it will make it easier to manage the wall geometry if you make each wall a separate group or component. Otherwise, it gets much more difficult to make modifications - all the wall geometry is connected together, and it’s hard to move or edit part without moving something else you didn’t want to.

But nonetheless, I think this is going in the right direction.

I still prefer to turn off Endpoints in the Styles, but you may prefer them on - your preference.

Happy modelling.

I have to say, this is one of the worst design and drawing tools I’ve ever encountered. Running through SketchUp’s own tutorials yields results that you can’t even produce when following the instructions to a T…awful awful software.

The first time I ran the self-paced tutorials, things worked fine…now they don’t. I can’t pull a line to create a raised edge or anything. It only chooses a surface and pulls that…sucks.

Push/Pull has never worked on edges are. It was designed to be used on faces. It’s easy to complain when you aren’t using the tools correctly.

Then perhaps you should take it up with the SketchUp team NOT to show a tutorial showing me to do exactly what you claim it’s not supposed to do.

Maybe you could share a link to the tutorial you claim shows Push/Pull being used on an edge. Back up your claim.