Layer don't unhide (or content vanished)

layers

#1

Hi there,
Three layers (Cellar, Roof and basement) of my model show nothing after I toggle their visibility. I tried many things but still invisible. Not much a big model so “only” two hours vasted to recreate the layers but as it is not the first time I want to understand what I may do wrongly. Sketchup Make 2017.
I posted it on 3d Warehouse. Any feedback welcome
Thanks!


#2

You are using layers incorrectly.
Layers do not separate geometry.
Layers are only for visibility.
All raw geometry should be on Laye0 and only groups and component given a layer tag.
Layer 0 should be the active layer 99.9% of the time, only change it once you have learnt when it can be changed.


#3

I appears that geometry is gone. It’s unfortunate that you are using layers incorrectly.

And Box has beat me to the punch. :wink:


#4

Thank you

Of course I am only using the layers to toggle the visibility (for the rest I am using groups) in this case hiding the Roof and Cellar layers to work on the kitchen. I created and edited much bigger models it is generally working, I only had this issue 3 or 4 times and if I am right, when saving the model with invisible layers. It is not about using layer to manage the geometry, I had many groups in these layers, but the entire layers content is gone and I did not, even by accident, erased the layers and the content. I maybe eventually erased by accident a group in an invisible layer, but all the groups inside the layer I don’t know how I could have done this. And even should I use the layers in a wrong way, this does not explain why the geometry is gone after I toggle the layers back to visible.
Thanks anyway, back to 3D


#5

Some more info about layers in SketchUp:

Layers in SketchUp aren’t containers. Edges and faces with different layers can still stick to each other which means they can easily be distorted when other objects are moved or be selected from tripple click and accidentally deleted, even when their layer is hidden.

To separate geometry into logical chunks, e.g. for levels, pieces of furniture, architectural elements, wood pieces or what ever you are drawing, use groups and containers instead. Then you can assign a layer to the groups and components from Entity Info and use layers only to control their viability (note how I say assign layer and not move to layer).


#6

Perhaps when you thought you were hiding the groups you accidentally hit Erase. They are next to each other in the Context menu. The visible result is the same. If you didn’t catch it immediately and undo the Erase action, the groups would be gone. If you’d used components instead of groups, erasing them from the model space wouldn’t have been a big problem because you could have brought out new instances from the In Model components library.


#7

I know…
But this explain nothing about my problem.
Thanks anyway


#8

It makes me wonder why, then, you don’t use layers correctly.

At this point I think you have to accept that you delete the groups instead of hid them. They are gone from the file you shared. At this stage you’ll just have to remake them. Before you go to that effort, you should repair the rest of your model.Put all edges and faces on Layer 0 where they belong and leave Layer 0 active at all times.


#9

The fact you have raw geometry on multiple layers suggests what happened.
When you hide a layer it doesn’t lock the geometry, so if you alter other geometry which is attched to the hidden geometry it can be moved or even deleted.


#10

I only used the Layer panel of the tray and the toggle visibility check box, not the Hide option of the Edit menu. I did not use components (yet) in this model

Thanks


#11

I know you didn’t use components. You should have been. It would have saved you a bunch of work.


#12

I agree, and have to clean the model, I group the geometry to avoid inferences between the floors, (any add-on to help cleaning the layers stuff like forcing an entire group to a specific layers?), but the entire geometry and all the groups vanished, it is not like I erase a single group by accident, the roof layer was composed of many independent groups, the Outliner don’t show these groups anymore :disappointed_relieved:

Thanks.


#13

At this stage of the modeling there is nothing repetitive, component will not have help me, yet.

Thanks


#14

Components aren’t only for repeated elements. As I wrote before, if you’d used components instead of groups, you’d have been able to restore your model by bringing missing components out of the In Model library. There is no such library for groups. When they are gone from the model space, they are gone.


#15

Here you can see edges that are on the Roof layer nested down within a group within a group where the rest of the group geometry is set to the Sol layer.
You really need to understand how Groups, Components and Layers work.
Another thing you need to be aware of is all your reversed faces, having back faces out can cause all sorts of issue, mainly making them invisible to many renderers.


#16

That sounds like you still don’t quite “get it”. I could be misinterpreting though, in which case please forgive me and take this as advice for others who may read this.

You don’t need or even want the contents of a group to be associated with the same layer as the group! In fact, as mentioned earlier, edges and faces should always associate with Layer0 regardless of what the group containing them does. Because it isn’t even the right practice, I don’t think anyone has made an extension that forces contents to associate with the same layer as the containing group. (There is, however, an unfortunate “feature” in SketchUp that many of us have complained about before: if you explode a group or component, SketchUp reassociates all its former contents with the former group’s layer. This is a way one can accidentally get edges and faces associated with the wrong layer).

Going the other way, there are several extensions that can force all edges and faces to associate with Layer0 throughout an entire model. TIG’s layer watcher goes a step further and monitors your usage to prevent you from making this mistake in the first place.


#17

Is this perhaps your missing roof (this group is associated with the roof layer)? If so, it was moved down to the floor level where is it obscured by other geometry. I moved it up for this screenshot.


#18

SketchUp Help Center : Controlling Visibility with Layers


#19

I understand that I have to “read the f* manual” a bit better, obviously there is something I missed in the principles. At best I will have to do a “I understand” reset and go back to square one of the layer stuff.
Practice does make perfect.
Right now it is midnight, so long for my after dark…

Thanks


#20

Yup! I learned this the hard way recently after reading the admonitions of the Great Ones about building all geometry on Layer 0 and then after creating a group or component to move it to a display layer. Since doing this my drawing’s been solid as a rock. It was driving me crazy losing hours of work. I’m also saving after major milestone in separate file names so I can go back to when the object was working right. Again, just leave the selection dot on Layer 0 and don’t ever move it.