Problem with Layers

This is my first model, so I have a lot to learn obviously. I have a problem with Layers. When i created the roof I made the building with walls, etc. a model, and then made a new layer for the roof. However when i turn off the layer now that the roof is built, it hides most of the building. What did I do wrong and how can I fix it? Thanks!

Roof layer off…

See this video tutorial http://www.youtube.com/watch?v=fBdP499iw0Y
To fix your issue go to layers manager and use the minus button to remove any layers you are using, when you do that the drop down will ask if you want to move contents to default layer, select it. Select the roof geometry you want on the roof layer and make it a component, use layer manager to make a roof layer, select that component and use entity info to assign it to the roof layer. There are many tutorials on the subject read more if you need.
Remember layers control the visibility of the model, components and groups are used to isolate geometry.

Hi westonlynae,

Layers in SketchUp serve a different function than you may be accustomed to in other software.

The sole function of Layers in SketchUp is to control visibility; nothing more.
When a Layer’s visibility is turned off, unprotected geometry assigned to the Layer will continue to interact and be altered by subsequent operations you perform … even though the geometry is not visible.

SketchUp Groups and Components isolate and protect geometry. aka 'grouping’
Geometry within the context of a Group or Component is isolated from interaction with other geometry.

Always keep the Default Layer 0 as the Active Layer.
Make geometry a Group or Component before you assign it to a layer other than Default Layer 0.
Groups or Components bear the Layer attribute.
The geometry within them remains where it must, on the Default Layer 0

Click … Widow > Layers … to open the Layers Manager
There, select and delete all layers except for the Default Layer 0
As you delete each layer, you’ll see a pop up window.
Select: Move contents to Default layer

Required reading before you contine using Layers in SketchUp:
Does SketchUp Support Layers? — SketchUp Documentation w/ Video

Then see the Components video tutorial here:
SketchUp Toolbar Series — SketchUp Video Tutorials

-Geo

2 Likes

[quote=“mac7595, post:2, topic:1155, full:true”]See this video tutorial http://www.youtube.com/watch?v=fBdP499iw0Y
[/quote]

tagged as private in the meanwhile, @mods: please reactivate.

I think the problem is that when you assign a group or component to a new layer, unfortunately the individual objects that make up that group, retain the original layer assignment, and so there is a conflict.

You can prove this as follows.
First make sure the entity control and the layer control are expanded and visible in the tray panel. Then create a new layer by clicking on the layer control plus symbol and make sure it is turned on (selected) in the layer list. Next select a group object on the original layer that you want to assign to the new layer, and in the entity control dropdown for this group item, change the layer parameter to the new layer name. Now in the tray layer control, turn off (deselect) the original layer, and you will find the group object stubbornly sticks to this original layer, and disappears from view. Now make the original layer visible again,and this time select the group object, right click on it then choose “Edit Group”. Now try selecting an individual object within the group, and notice how it has the name of the original layer, even though it sits in a group with the new layer name.This is where the conflict comes from.

A quick and easy fix is as follows. When you are in the edit group mode, right click and choose “Select” then “All connected”. Then in the entity control panel, from the layer dropdown select the new layer name. This will reassign all the internal objects to the new layer, thus matching the group layer name, and effectively remove the conflict.

Now when you turn off the original layer, and turn on the new layer, the group object appears.

@lakeskiwi, a better method is to follow the guidance given in the Knowledge Center. Always leave Layer 0 active, always keep primitives (edges and faces) on Layer 0, and only make layer associations for groups and components.

4 Likes

@DaveR, That is fine if you remembered to do so at the beginning, but confusing and annoying if you havent been so disciplined with your drawing from the start, or simply didn’t know. Also if your change your mind later and wish to reassign a group object to another layer, you run into this issue. What I have attempted to do, especially for new users, is to explain why this happens with group objects (or components) and how to easily fix it, without having to put everything back onto layer 0.

1 Like

It’s better for new users to learn the correct work flow rather than have to develop work arounds to compensate for not using layers correctly. There are extensions that will return all primitives to Layer 0 where they are supposed to be left. One very use extension that can do this is ThomThom’s CleanUp3 which is available for automatic installation in the Extension Warehouse.

I hope this sums up “use of layers” right:


Correct me if I’m wrong.

1 Like

Thank you. @Lakeskiwi
I think everyone learns differently. I understand the idea behind learning and doing something a certain way from the start, but there is value in understanding the concepts at a deeper level. Your info can help someone who has made a mistake, changed their minds, or in my case, imported an Archicad file and is trying to make sense of the layers that came in. Thanks again.

-just checking - the group changes to the layer you have selected but they remain on layer 0 individually, right? ( -if ungrouped or edit select they would still be assigned to layer0)

So long as you don’t explode the group, it’s contents continue to use their original layer. But when you explode a group or component SketchUp resets the former contents to use the group’s layer.