Issues with hidden and unhidden layers

pro
sketchup
2016
layers

#1

Hey guys , so i have always been working in layers, and i tend to hide the ones I’m not using to make it easier to work, and then unhide them, however this time when unhiding layers they still do not show…i have tried many things like unhide all , and the hidden geometry i checked too…If someone knows how to fix this, please let me know


#2

With so little info to go on my guess would be that you are using layers incorrectly.
Layers do not separate geometry, Groups and Components do.
We need to see more, images or better yet, the model itself to diagnose your problem fully.


#3

Without seeing the model this is a guess, but I suspect you have associated geometry or nested components/groups with a layer that is still hidden. Never associate primitive geometry (edges, faces) with anything except Layer0, and be wary if you associate nested components or groups with different layers than their parent.

Also, note that “Unhide all” refers only to entities you have hidden, not to layers. Also, “all” means “all within the current edit context” (this is not intuitive or obvious).


#5

So for example as can be seen , my floor and my facade at the front of building and some walls are gone, even though they are unhidden, I’m unsure if i have worked in layers incorrectly since i have always been working in this way and never had problems, so if you guys could tell me what i can do to sort it from this point… @Box @slbaumgartner


#7

Unhide only applies to the current modeling context.

Instead, check ‘Hidden Geometry’ to see all hidden edges as dashed/dotted lines (and faces).
But you also need to check all layers to be visible at the same time.
Plus you may need to uncheck section planes, so they don’t interfere fith you model in anyt way.

Only now you can dig into groups and components to bring geometry back to Layer0

Otherwise share the model, not just a screenshot


#8

Neither image helps. We can’t see the structure of the layers/groups/components.
Without the model it is guessing.
Have you moved the active layer?


#9

As the others have also said, we really can’t diagnose this without examining the model. If it is 3MB or smaller you can attach it directly to a reply here using the little button at the top of the reply window. If it is larger, you can upload it to either the 3d Warehouse or your favorite file sharing site and post the link here.


#10

Im unsure of the whole active layer and layer 0 thing that you guys refer to, in terms of how to work with it, i have been doing what i usually do, separating different groups , adding layers, going to entity info , and giving each the specific layer allocated for them. Here is the model, to see the issue @Box @slbaumgartner @Wo3Dan , Its a large file so heres the jumpshare link that you guys should be able to access. http://jmp.sh/lHC7e3k


#11

Just to let you guys be aware of what really is missing and yet is not hidden in layers manager, it is the FLOOR layer, ROOF layer, left small wall layer, facade layer, floor layer ,fire door layer, i think thats about it… @Box @slbaumgartner @Wo3Dan


#12

For starters, as we suspected you are not using Layers correctly. I found 870 primitive entities associated with layers other than Layer0. Most (820) of them are associated with layer “seating”, but there are 10 in FLOOR, 38 in mezanine, 1 in mez void, and 1 in mezanine glass. I can fix these, but I want first to look for other issues as the file is quite large.


#13

When u say associate, i should add and name layers when on layer 0 (so when layer 0 is active)?

as for a lot of those 820, only few are mine since I’ve been given the file as is and edited some of it to make walls, furniture and so on separate layers… I’ve been just pressing plus, naming it then selecting something in model and giving it the specific made layer…which i see is incorrect now…ok thank you, if easier for you, you can tell me how to do it and i can fix myself. @slbaumgartner


#14

It’s too late at night for me to delve further, but a simple Purge of your file sent it from 211mb to around 9mb.


#15

All geometry must be created and remain on the Default Layer0
That means, always leave the Default Layer0 as the Active Layer.

The alarms sound when we open a ‘problem’ model and find Layer0 is not the Active Layer.
This the Layer Manager when I opened the model.

Groups an Components may be assigned to other layers.
However, the raw geometry within their context must always remain on Layer0





Learn to clean up the unnecessary layers that come along with your CAD imports.


Learn how to keep file size down and performance up.
How do I make SketchUp run faster? — SketchUp Sage Site



One could reduce file size and improve performance even more by eliminating unnecessary ‘stuff’ that in all likelihood will never be seen.
Like this tiny screw Component for example, with two groups nested inside.

@Sengul
This is the stuff sluggish models and bloated files are made of:


#16

I say “associate with” because in SketchUp a layer is a sort of shared flag that an entity can reference (associate with) to control its visibility. Unlike in most 2D cad and some other 3d applications, a SketchUp layer does not own, gather, or isolate entities and there is no concept equivalent to “stacking order”. We have a tradition of using the unfortunate language “entity is on LayerX”, which leads people with background in 2D cad to misunderstand what SketchUp’s layers do.

The “active” layer in SketchUp is the one that any new geometry you draw will associate automatically. SInce you are normally drawing primitives (edges, faces, surfaces) you should always leave Layer0 active. Once you create a group or component, you can associate that group or component with another layer to manage visibility. There is one gotcha though (which many of us consider to be a bad design): if you explode a group or component, its contents become associated with whatever layer the group had. So, you can work correctly but unknowingly get primitives associated with the wrong layers.

There are various extensions you can install that will scan your model for primitives that are associated with other layers and correct them to Layer0. E.G TIG’s Default Layer Geometry. When a large number of entities need correction, this can be a major time saver.

However, after all of that, I don’t detect any hidden geometry or other non-visible entities. I don’t know exactly what you mean by “my floor and my facade at the front of building and some walls”. I know it is awkward to point to something that isn’t showing, but could you perhaps annotate a screenshot to indicate where you think something should be present but is not?


#17

By “floor” are you referring to the way the furniture is floating in mid air? If so, I can’t find any floor object, hidden or otherwise, to support them.


#18

Yes there was elevated ground, and these too for example, all gone,as well as the empty wall as you may see, which in my layers is named “left small wall” @slbaumgartner


#19

Sorry to say, when I did the “purge unused” those layers (and many others) vanished, indicating that there was nothing associated with them. I don’t know how they came to be missing, but I think you are going to have to redraw the errant parts.


#20

There were 89 layers in the file; most were unused.
26 layers remain after purging the file.

To me, that’s still overkill for such a simple model.
You can clear the slate and then create just the layers you need.

• Open the Layers Manager; select and delete all layers.
Layer0 is a permanent fixture. It cannot be deleted.
There is no risk of losing anything except the unnecessary clutter of layers.

• As you delete them, you’ll see a pop up window. Select: Move contents to Default layer


#21

Thank you very much, i understood what i need to do to have less layers to work with and less of a heavy file, appreciate the time and help @Geo


#22

Hi, thankyouu so much for the time and help, I’ve understood the issues you and the others have discussed in terms of working on the default layer 0 when adding layers and so on, and since you were unable to find a way to retrieve my layers that disappeared I’ve just had to start fresh on the model that has all exterior walls and facade on. Hopefully following what you all have said, the issue won’t come up again

Thank you again @slbaumgartner