Invisible groups


#1

Hi all, Ive been using sketchup successfully for a project but ive run into a problem I dont understand. Im finding groups on layers that are invisible that I cant unhide. I go to outliner and select them and the blue grouped boundry box of them shows up each selection but they remain invisible even after selecting unhide all.

so they do seem to exist

any suggestions on how to trouble shoot this issue?

cheers


#2

Unhide only works on entities in the current modeling context.
So be sure that the hidden entities aren’t entities hidden from when being inside the group(s) or component(s).

Example: hidden edges in a group remain hidden with the operation “Unhide” applied to the group.
They become visible when entering the group and only then applying the same operation “Unhide”.

Also be sure that basic (ungrouped / raw) geometry (edges and faces) stil have Layer0 assigned to them. Only groups and components should have other layers assigned to them when needed.


#3

Added to that, you can unhide by right click within outliner, but be aware that if you have also hidden the layer it won’t show. Try not to hide things, rather group them and assign them to a layer and hide the layer.


#4

Good point about layers being made invisible. I was more focussed on hide/unhide and forgot about the necessity of the appropriate layer(s) to be visible too.

@jedics, use layers on/off to controle your model’s visibility in general.
Hide is more for temporarily getting things out of the way when modeling.


#5

I agree, that is what I use hide for and it is rare that I do.

thanks for replying so thoroughly but I still dont really understand yet, I go to outliner and select the entitiy and it its blue bounding box comes up but how to I get it to re appear ?


#6

r-click and un-hide.

If you turn on “hidden geometry” from the view menu, it’s relatively easy to find the hidden stuff… only problem lies when you want to un-hide only one element and others obscure it and make it hard to select.


#7

This is highlighting that you are using layers incorrectly.
Always keep raw geometry(faces and edges) on layer 0 and only assign a layer tag to groups or components.
What you are seeing with the empty bounding box is a “Group” on one layer and it’s contents on another.
There are several ways to change the geometry’s layer, In this example I delete the layer to force the geometry to layer0, but you can change it via entity info and keep the layer intact.


#8

hey thanks for the input, Ive been looking at the video lots in between all the other stuff IM doing but Im not sure its solving the same problem. For example here the solar panels are not hidden yet the only way I can view them is with ‘hidden geometry’ turned on. They dont appear to be attached to any other layer.



#9

its the same in outliner:


#10

I think you’ll find it is exactly what I have been trying to explain. The geometry that is hidden is not on the layer you think it is. So you descend into madness.

All Raw geometry must be kept on Layer0.
Layer0 should always be the Active layer. (unless you really know what you are doing and why, but 99.9% there is no reason to change it)
Only groups and components should be assigned a layer and only for purposes of visibility.

In your screen shot you have the dot to the left of Skirt meaning it is the active layer, suggesting that you have been creating raw geometry on layers other than layer0, then grouping and putting the group on yet another layer…so you have lose track of what is actually hidden and where.


#11

I expect that @Box is completely correct. If you can upload your model where we can examine it, we could give you absolute proof and specifics.


#12

what do you mean by ‘raw geometry’?

If I turn of a layer, roof solar for example it disappears so doesnt
that mean its on that layer?

even if I turn on all the layers the hidden stuff remains hidden so
while how Im working might be wrong how does it explain an object that
is invisible even if every layer is on?

Your right about the madness :slight_smile:

Ok lets go back to basics, lets say I start a new project, I start on
layer 0 and created a rectangle and extrude a box, then I create a new
layer ‘1’ select it as the active layer and select my box and press G to
group it which in turn makes the entity window come up saying it is on
layer 1.

now say I want to cut a hole in that box, I do it on layer 1 yes?


#13

No! The hole is made in the content geometry of the box, which must all remain on layer0.

Also, there is no need to make layer 1 active to put the group there. Leave layer0 active, create the group, and then use the entity info window to associate it to layer 1.


#14

so far so good…

No, you can make it now, but do not change the active layer

then, assign your group to Layer1 as Steve beat me to say…

No, you just stay on Layer0 and edit by double clicking the group…

john


#15

I find that I sometimes need to explode a group (or component) to merge in some other geometry. Then I re-group them. However, I’ve noticed that the exploded items, originally created on Layer 0, end up in the layer of the parent group. “Moving” a group to Layer 0 before exploding it eliminates this problem. Or “you descend into madness,” as Box pointed out.


#16

Yes, Jim, this somewhat illogical behavior has been there for a long time. It is one way the innocent often unknowingly get primitive geometry associated with other than layer0. There are various plugins available (including one of mine) that provide a safe explode to avoid this.


#17

So i tried to upload my model but it was far to big(25meg) so I created a copy and deleted 90% of the layers and its still 20meg. Is there a way to purge anything not visible?

by the way, what are you guys using to show the animated examples, they are very useful. On mac here.


#18

So where is the use of being able to make any layer not layer0 active?

jimhami42
IT Took a while to sink in but this demo is probably my whole problem as on many occassions I would delete a layer and move it to another trying to clean things up etc. If this leaves data behind (eg. basically doesnt work properly) then WOW, no wonder I couldnt get things functioning

note to self always move to layer0 before moving to a new layer :slight_smile:


#19

Anything new you draw will have the active layer assigned to it. Not desirable if it’s not Layer0

Anything group or component you copy or new components brought in through the component’s browser will also have the current active layer assigned to them. This may be desirable vs doing so one by one later.


#20

Ok makes sense, thanks.

I still have this issue of my solar panels apparently hidden but this is not the case as show in the outlinder here:

Id upload my file but as I said before its 20 meg even after deleting 90% of my content.