Invisible groups

If it is hidden as you show but not showing in Outliner then it could be loose geometry, and it is most likely not on layer0. It could also be within a group and the group is visible but the geometry in the group isn’t. Even you latest screenshot shows you have a different layer active.
A 20 meg model can be uploaded to the 3d warehouse and a link added to your post.

ive tried uploading my file like 6 times, fails to complete every time.

try “Window | model info | Statistics | [Purge unused]” before uploading

If you double click on the hidden bit, then r-click and see if there is an “un-hide” option. If not, double click again and have a look. And again…
The hide command works on the nesting level you are in: {I’m using “group” but it could be “component”}

  • main working space
  • group
    • entity
    • entity
    • entity
  • group
    • entity
    • entity
    • entity

You can hide a group - all entities within it are hidden, but you will not be able to un-hide a single entity within the group: it’s the “wrapper” that holds the entity that is hidden so everything within this wrapper is hidden, or nothing is. If you are within this group, then there is nothing to “un-hide”.

You can hide an entity - only that instance is hidden, but you can select all entities within a group and hide them. In this case, the group “wrapper” is visible, but you can see no entities within it so on the main level, there is nothing to “un-hide” because the hidden stuff is within the wrapper.

Then you get complicated when you get groups within groups. This is why people recommend using layers rather than hiding and un-hiding stuff.

To the Forum? or to the 3D Warehouse?
The forum will only accept 3mb the warehouse will take 50mb.

3d warehouse

Sent from Samsung Mobile

thanks gadget for the purge function.

I think i get what your saying about the nesting of groups. I looked at them though and it doesnt appear to be the issue. I’ll be interested to see what you guys think.

Jedics House smaller.skp (281.9 KB)

Is this more like it? You have hidden primitive geometry nested deep inside groups or components. Dig down into the innermost contents and unhide the faces and edges.

You have so many nestings going on in there with things on different layers within the nest things have to get lost.
Read how to use layers.
Keep Layer0 as the Active layer.

I only started using SU a couple of months ago and clearly Ive still got a lot to learn.

How did you get the panels to show again? You say dig down to the inner most, Ive looked at everything in outliner that is in the group and there is nothing there to unhide.

You have groups nested inside groups nested inside groups… You have to keep opening for edit until you get to the most deeply nested groups and then unhide all. An alternative is to install an extension such as Tomasz’s Unhide All (available free on the sketchUcation store) which automatically goes into the nesting for you.

thanks for that plugin, it got the panels back. So Ive been trying to tidy up my groups inside outliner by trying to drag entities out of the group its nested in so I can then put it on its own layer but SU insists on maintaining the entities relationship with the group I just took it out of.

this is maddening, can i fix my model?

what are you guys using to show me video examples?

Steve and I both use to make gif’s on our mac’s

it’s free, it’s a tad old fashion but very simple once you get the basics sorted…

gif’s are easy to add in most forums…


very handy app :smile:

see how its showing that its still grouped even though its no longer within it in outliner?

I think the view’s blue selection box is confusing you. This box is always a rectangular prism that is big enough to contain all of the Group’s contents. But seeing something inside the selection box is not proof that it is nested in the Group. Consider the attached screenshot. The large box and the cylinder are nested in a Group. The small box is not nested. But because the selection box for the Group must be large enough to capture both the large box and cylinder, it also visually contains the small (not nested) box. If you look closely, the nested items are highlighted in blue, but the small box is not, because it is not part of the selection.

Also, if you look at the Outliner in your gif, there is a little arrow to the left of the item for the Group. This arrow points right, indicating that the nested contents list for the Group has been collapsed in the Outliner. Click on that arrow, it will change to a down arrow, and the nested contents of the Group will be listed. One or another of the nested items is far enough from the wagon to require the selection box to extend out over the table base/shelf. Without your model I can’t say what is there - it could some other group, loose geometry, or even a duplicate copy of the table base/shelf that you unknowingly created.

Another thing you can try is to set View->Edit Component->Hide Rest of Model. Then open the Group for edit. The rest of the model will disappear. Everything you see is contents of that Group. You should be able to easily spot what is out there with the table base/shelf.

Oh I certainly am confused :slight_smile: It did however turn out that there was geometry within my group and once I deleted it the boundry box reduced in size. But I have other instances of the same thing, there is nothing in outliner showing geometry that is clearly with in the group.

Another thing I find wacky, when you make a component it gives you the option to call it something unique but when you make a group it doesnt creating a lot of useless list with the word ‘group’ in outliner wtf?

The outliner shows only Groups and ComponentInstances, it does not show loose geometry (Edges, Faces). So there can be loose contents in the Group that are not listed by the Outliner. Think what a useless mess it would be if the outliner tried to list thousands of Edges and Faces! So, when you expand a Group in the Outliner, you won’t see any non-Grouped nested geometry listed. You won’t even see any indicator that it is there. You have to open the Group for edit to access it.

As you observe, there are some quirky differences between Groups and Components. The differences mainly arose back in the early days of SketchUp when these were different beasts. Today, Groups are actually a special restricted kind of Components. Both use a ComponentDefinition (CD) to actually own their contents. If you make a copy of a Group or ComponentInstance, the original and the copy continue to share the same CD. But if you edit a copy of a Group, SketchUp clones the CD so that the original and the copy become independent, as required by the semantics of Groups. In contrast, if you edit a copy of a ComponentInstance, you actually edit the CD and any changes are immediately propagated to all the copies.

Some additional behavior from the old days carries on. When you create a Group, its CD is automatically assigned a sequential name such as Group#23. You have no access to this name and can’t change it. When you create a Component, the default name for its CD is similarly Component#5, but this default is visible in the create component dialog and you can change it.

You can also assign an instance name to each Group and to each ComponentInstance. You do this via the Entity Info window, though, not via the creation dialog. To repeat, you assign a CD name in the create Component dialog, you can’t assign a CD name for a Group, but you can assign individual instance names to both Groups and ComponentInstances using Entity Info. The Outliner will display the unhelpful generic “Group” for an unnamed instance, but it will replace this with the instance name if there is one. For a ComponentInstance it will display both names, as “instance_name <CD name>” (it will omit the instance_name if you haven’t assigned one).

It is a good practice to immediately assign instance names to your Groups and ComponentInstances. Otherwise, as you have seen, it becomes impossibly confusing to tell what you are manipulating in the Outliner. It is also also a good idea to assign CD names for Components, as this makes it easy to keep track of copies even if you haven’t named every instance.

Ok, started moving the loose geometry to where it belongs, really appreciate ya help.