I think ive hidden some edges and lines, I cant unhide them


#1

Hi people,

I think I may have used the eraser tool and hidden some lines. Ive tried Unhide all and view hidden geometry and it hasnt revealed the edges or lines.

Basically I have a flat surface which seems to be broken into several smaller pieces without the lines or edges of the shapes. Ive tried deleting all the shapes and redrawing one single shape and the same smaller shapes are still there.

How can I fix this? Thanks in advance people


#2

It’s not really feasible to diagnose the problem from just your screenshot. Please upload the model itself.

-Gully


#3

I was just purging my layers so that I could upload model and I think that might have fixed the problem as the lines are back?? though I dont know if that was the reason why the lines are back. Anyway false alarm, will update if it happens again.

Thanks again Gully_Foyle


#4

You didn’t perchance move faces to a different layer than their bounding edges, did you? If so, this is an example of why we all recommend keeping all primitive geometry on layer0.


#5

I havent corrected the layer issue yet, so everything is on a different layer to the default layer 0. Will have to look into that if thats the cause. Still need to get my head around sku’s Layers 0

Problem seemed to fix itself as I purged layers and deleted geometry to get model smaller and noticed that the lines are back. Models abit messy at the moment


#6

One of the perverse aspects of SketchUp’s layer system is that a Face (or surface) and its associated Edges CAN be associated with different layers. If you hide one of the layers, this can make the Face visible without any Edges, or the Edges visible without any Face. Again, this is why we tell you always to keep all primitives on layer0.


#7

Ok I think Im going to need to sort the layer 0 thing out now before I go any further. As ive just discovered while modelling extra geometry that its just not appearing or just disappearing. Now ive got the lines and edges and not the surfaces. Im just forgetting what layer im modelling in…

Ok if I select everything and place everything into Layer 0, this will make everything manageable and sort out phantom disappearing lines and surfaces?

Thanks


#8

[quote=“twangdy, post:7, topic:16366”]
Ok if I select everything and place everything into Layer 0, this will make everything manageable and sort out phantom disappearing lines and surfaces?
[/quote]Provided nothing is Group or Component. You will have to edit a Group or Component to move its contents to layer0 (or use one of the various fixup plugins - including one of mine - to do it for you).


#9

Thanks Ive just gone back to read your post on Layers and primitives. When I started I thought that I kept it quite tidy. I think I’ll be a while


#10

Im uploading my model… The problem im encountering now is sort of related to the original problem. Before I couldnt unhide my hidden lines, that problem sort of fixed itself. Now I’m trying to pull a ceiling down to some small internal walls and the ceiling or surface disappears leaving an edge around everything else? Im making sure im on layer 0 while im pulling the surface and ive grouped the building and it resides in layer 0. So cant figure out whats happening right now.

Ive purged the layers and purged from statistics, deleted duplicate geometry, Unhid hidden geometry. Mostly everything should be on layer 0, the lantern components might be on another layer.

thanks in advance people

138 merton road purge copy.skp (2.5 MB)


#11

Had a quick look at your model. You seem to have made very little of the geometry (faces and edges) into groups or components, especially in the main walls, roof, ceilings and windows. That causes great difficulty when you try to edit it.

Try selecting each face in turn with a double click (which includes the edges), then making the selection into a component (press letter G) or group (menu Edit/Make Group). Make sure if you used Component that you check the box that says ‘Replace selection with component’ (it isn’t checked by default if you have other ‘loose geometry’ attached to the selection, which in your model you mostly will have).

Other problems I see in the drawing:

  • The white roof section is not flat - there’s a diagonal line which if removed, deletes the face that should be there.The ridge line is higher at the open ‘front’ than at the back. But since your near end wall is at an angle to the axes (in plan), you won’t easily be able to have both roof sections in a single plane each. Hard to build that!

  • Most parts of your walls, windows, and roof have no thickness - only a thin outer shell. Try re-modelling them using the PushPull tool to give them ‘real’ substance.

  • Your model is quite some distance from the origin, and you have the (irrelevant) default person in your drawing near the origin. Delete the person, then select your whole model and move one corner to the origin.

It would repay you to make the effort either to draw the model again ‘from scratch’ making each element into a group or component as you go, or (not easy - I’ve tried) to convert the existing model, a face or element at a time into groups and/or components.

Best wishes.

John McC

PS. I attach some notes I made last year for a colleague who was learning Sketchup. You may find them helpful, particularly the use of shortcuts (built in and your own customised ones), and the process of making drawing elements (a) correspond to real world ‘things’ like wall, floor, ceiling, or window frame and (b) create each element as a component or group as you draw it, so its geometry doesn’t get tangled with other elements, as is the case in most of your drawing. ALWAYS, ALWAYS, draw original geometry on Layer 0, then make it immediately into a group or component (components are quicker using shortcut key G).

Using Sketchup.pdf (31.2 KB)