Hidden lines still showing

Lately I’ve been having this problem with my sketchup model, the hidden lines show in light gray. It’s weird because it only happens in certain positions, if I rotate the model they disappear. Any idea why this is happening?

Thank you!!

That’s not the edges showing. It’s your graphics card showing the back face color. You could edit the the style to make the back face color closer to the front face color. It also might help to hide faces that can’t be seen anyway.

Thank you!! I’d never thought of that!
I have a good graphic card though, and this had never happened before, any chance SketchUp is not detecting the graphic card? or that is irrelevant?

You can look under Preferences>OpenGL or Preferences>Graphics depending on the version of SketchUp. It could be that the integrated GPU is being used instead. Probably more likely that you’re just butting heads with limitations in OpenGL.

You can make that bleed through more obvious if you change the back face color to something like magenta.