Deleted Edges problem

triangulation
edges
planarity
non-planar

#1

i want to remove unwanted hidden lines in sketchup


#2

Could you attach your model? There are difficulties trying to answer based on your image. For one thing, I don’t see any hidden edges (hidden normally displays in a dashed pattern). For another, I can’t tell what is or isn’t a group/component (you can’t delete things inside them without opening for edit). Finally, I can’t tell from the spiderweb in your image what is going on in 3D; all depth is lost in the image.


#3

this is how my model looks


#4

and when i selected the faces is is splinted to many hidden faces


#5

That normally suggests that the face isn’t flat. You may have drawn or edited it so it is nearly, but not quite, flat. Not at my computer at the moment, so can’t be sure.


#6

i want to delete those hiden edges from my wall faces so that i can export it into 3ds max


#7

yes exactly @john_mcclenahan i need a solution for this i have a huge number of faces like this to be solved


#8

Turn on Hidden Geometry in the View menu and then erase them. Assuming the surrounding edges are coplanar, the faces should remain when the hidden edges are deleted. If the faces start getting deleted, too, the culprit is likely a lack of planarity with the remaining edges.


#9

Usually the simplest way to fix it is to delete the distorted face completely and redraw it, paying very careful attention to inferencing hints. And to group or make components as you go, so you don’t risk moving vertices by accident later.


#10

Or try first what DaveR suggests, and delete and redraw if that doesn’t work


#11

thank u :slight_smile:
BUT
I have so many faces where and which i can’t do it manually, so that i came here for a better solution @john_mcclenahan


#12

It take a little effort on your part and posting model is key to that so what is delay???


#13

can u please tell it in briefly @DaveR


#14

Really, the only solution is to draw it properly in the first place, and use components or groups to separate geometry. Looking just at your image, ALL the geometry (or at least the edges) highlights, which suggests it is all connected and in the same context, not made of separate components or groups. That way lies only frustration and disaster.

But do as DaveR suggests and upload the model. Use seventh icon from left above where you type to upload it, if model is less than 3MB. Otherwise, upload to a file sharing site like Dropbox and post a link to it here.


#15

I thought I did.

  1. Go to the View menu.
  2. Turn on Hidden Geometry.
  3. Use the Eraser tool to erase the hidden lines you don’t want.

#16

Unfortunately, you have to make the effort either while creating the geometry in the first place or while trying to fix it afterward (which usually takes more effort). Once the mess is made, there is no quick or automated fix because for all SketchUp knows you meant the model to be like that.

In the future, pay closer attention to the inference snaps and enter precise values in the measurements box while drawing. And, as John and Dave have said, use groups and components to keep your model from being one giant entangled web.


#17

You can use Thomthoms CleanUp plugin to delete the edges between coplanar faces, if some of the unwanted lines are there afterwards, the connected faces aren’t coplanar…


#18

Why will you not post model or is it easier to ask question vz. the next to nothing effort to do that=> you’ll get much quicker answer!


#19

There is a Super Easy way to remove ALL hidden geometry at once but it only works on Exploded geometry and with the hidden geometry not showing.

Just Cut all desirable EXPLODED geometry that is selected to the clipboard,
Select All. If you turn on hidden geometry here you can see what you are going to delete.
Delete. You will now have an empty component.
Past in Place. All clean geometry will be back in the component.


#20

Thanks you to DaveR,

Fantastic, simple instructions, i followed your 1st sentence and it worked.
Only thing i would like to add: if you are going to hand pick the hidden edges to delete (rather than deleting the entire area as a whole) - make sure you go over the affected area with a fine toothed comb, i found a few sneaky hidden lines that were only a few mm long, at the point the mass of lines converged if that helps.

I tried redrawing the wall many times, in different ways, nothing worked because these hidden lines were screwing with the new wall. I assume the hidden lines happened because i stretched a wall corner somehow during my drawing process, easy to let slip if the wall looks the same along the way. I even got into the habit of making all walls a group: so draw the outside wall and complete the doorways and window openings, then triple click and make group, cant remember who’s YouTube i watched (youtube “Rio Ryne”), but noticed he did this (among a million other things to make his drawings amazing), and it all seemed to make sense, i used to draw my entire drawing without making groups, man this made things hard if you wanted to move anything as it was connected to everything else. Making groups to separate parts of your drawing allows you to edit just that bit if needed.