Support for Sketchup 2017?

sketchupexpert

#1

Although my trial will soon be over and I’ll be back to Sketchup Make, I am trying to create a drawing with the current version. The problem is that every time I go looking for help on how to do something the help files do not appear to relate to the new version, for example, I could not get a layer to appear exactly on top of another. It was doing some form of snap that left it unaligned. I went to help and it said to go to Arrange/Grid Snap Off but I don’t have these menu items in my version.

Appreciate any help.

Thank you


Deleting your own posts - let's talk about things!
#2

I expect you’re looking at the Help files for LayOut, not SketchUp and that’s confusing you. Arrange/Grid Snap Off is a LayOut thing. It is not a SketchUp thing.

You should read the SketchUp help files on Layers too. Layers in SketchUp cannot be stacked. That sort of concept doesn’t apply to SketchUp layers. In SketchUp, layers only control visibility of entities assigned to them. Stacking would be done in the 3D space just as if you were stack real objects.


#3

Dave is likely correct.

Another common pitfall is to have the wrong version selected for the documentation. See the red oval in the attached image…


#4

Thanks. I’m just wondering what I am doing wrong then. I have the basement layer with the walls. Then I am trying to place a layer called slab on top of the basement layer so that I can extend it out to the garage. Every time I get close to being able to place the slab directly on top of the basement it sort of snaps back and forth, up and down and will not let me place it correctly. I may have looked in the wrong place again for help, but the arrows do nothing. I thought I could select the layer/component and nudge it with the arrows. No luck.

Every time I start the program and select to open a file I get not responding for a few seconds. Does that indicate problems?

I thought that when I made something as a component that I would then be able to select it by just clicking once. That’s not working.

Is there a way to add a layer for the ground? I want to size the lot to place two houses and add some landscaping like grass and plants.

Appreciate your help.


#5

If the slab is a component, that sounds like it may have the glue-to property set (which can happen automatically it the geometry you selected to create the component was sitting on an unselected face). Open the Components window, select the slab, and click edit. See whether the glue-to selector says “none”.

This usually means you have a lot of extensions and it takes Ruby some time to load and initialize them.

That should work. Check that you don’t have duplicate geometry left when you created the Component (which happens if there are things touching it and you don’t check “replace selection” in the component create dialog.

There are multiple ways to do this, ranging from drawing a rectangle to geolocating the model. Bear in mind, however, that SketchUp’s layers do not isolate geometry. You will need to put your ground into a group or component to keep things from sticking to and merging with it.


#6

Gary,

I’m sure I’m not the only one here sensing some confusion on your part.

First: Are you using SketchUp or Layout? As @Marc mentioned, you may be looking at the wrong set of documentation online! Layout and SketchUp “Layers” are completely different concepts that (unfortunately) share the same name.

It sounds to me as if you are trying to use SketchUp, not Layout. And that you haven’t (yet) internalized the essence of Layers in Sketchup.
Layers in Sketchup:

  • Are used only to control VISIBILITY
  • Do NOT isolate geometry. Geometry associated with one layer will interact with geometry associated with another layer.

In order to isolate geometry in Sketchup, you must use “groupings” (which I’m going to use as a shorthand for the actual SketchUp entities called “Groups” and/or “Components”) Except when using certain tools that intentionally interact across groupings, what happens within a grouping doesn’t change loose geometry (geometry NOT in a grouping) or geometry in other groupings.

The isolation is NOT complete in one way: SketchUp’s inference engine can pick up inferences external to a grouping. This is useful - nay essential - when you want to move one grouping to “line up” in some way with another grouping. Once you make the move using the inference, the grouped geometries remain distinct.

SketchUp requires that you always have a Layer named Layer0. It will save you a lot of headaches if you keep all primitive geometry (edges and faces) associated with this layer. Group together geometry in a way that makes sense with your conceptual model, then associate the grouping with another layer. But don’t open the grouping and associate the geometry itself to a layer - leave the geometry associated with Layer0!

If you do this, ALL of your geometry will be associated with Layer0, but each grouping will be associated with the visibility layer you assign - allowing you to turn them “on” and “off” using the Layers tool.

I think your modeling will improve once you’ve internalized this.


#7

Wow! Thank you! Thank you! You guys are SO helpful. Obviously I have a lot to learn but I’ll get there with this kind of help.


#8

response from slbaumgartner

Point One. This seems to be the root of some of my issues with Sketchup. It seems that wherever I go looking for help it refers to menu items I don’t have or can’t find. You said to go to the components window and then edit it, but I can’t find either of those.

I’ve enclosed the drawing in case you want to see what’s up with it. I am trying to move the slab to be directly on top of the basement layer.

Thanks!heritage_01.skp (2.6 MB)


#9

Your slab isn’t in any grouping. Nor is your basement. Consequently, when you tried to move them together they merged. And at some point, you managed to move points and/or lines such that one wall of the basement (the “front” wall per the axis of your model) has deformed. I tried to correct it for a few minutes, but I’m now convinced that redrawing it from scratch would be quicker. Here’s the approach:

  • Start with the floor of the basement. Give it depth so it is a slab in 3 dimensions, not (as you have it now) a 2d plane. Select it all and make it a Component (I prefer components since you can NAME them)
  • Once you have the Slab Floor, draw the footprint of the basement walls on the slab floor - but be sure you are NOT “inside” the Slab Floor component. This will create geometry - bound in a single plane - that doesn’t merge with the Slab Floor.
  • Use Push/Pull on the footprint to create the actual walls. Once created - make the walls another component.
  • Finally, make your slab that will be the roof of the basement. Again - make it a component.
  • Now think about visibility and associate both the Slab Floor and the Slab Walls to the layer “Basement”. Perhaps - associate the basement slab roof to the same layer - or a different one - it’s your choice! Decide based on your conceptual view of the model as a whole.

#10

Here’s a quick .gif I did. I stopped after creating the floor and walls to show layer assignment:


#11

Maybe this is better?heritage_01.skp (2.6 MB)


#12

Couple of questions on your GIF. I get what you are suggesting but it’s not my issue. First, the walls and floor are the basement so they need to go down, not up. No big deal, but the problem is I then created a component, slab and a layer, slab and then wanted to put the slab directly on top of the basement. I redrew the slab and although it kept changing size or perspective I did mange to get it on the basement walls, sort of. I did see some empty walls in the basement so I agree that I’ll start the whole thing over again and be more careful.

I’m still struggling with selecting things. I made the slab a component but after I moved it close to the right location on top of the walls and then tried to move it ever so slightly it either deformed or moved the basement as well. If I just single click on it even though it is a component it just selects one part, the face for example and moves that. Not what I want obviously.


#13

I don’t see any grouping for the slab:

The above is the Outliner tool. It shows all groupings in your model. It looks like your slab is a 2d plane:

Here, I made it 3d, assigned it to a named component, then moved it into the alignment I think you want:

I’m refraining (for now) pointing out that some of your geometry (not the groupings) has been assigned to a layer other than Layer0.


#14

I do apologize but I have not been able to even find the word geometry anywhere. I’ve almost got it exept that the slab layer snapping all over the place is making me very frustrated. I redrew the basement to be 40’ by 20’. The new slab is also 40’ by 20’ but I can’t get them to align. I must be missing something. One thing that appears to be missing in Sketchup is to be able to set a location, for example, top/left/right/bottom. That makes it really easy to align objects by just setting the same top or bottom.

Updated drawing attached. heritage_01.skp (2.7 MB)
.


#15

OMG! Got it! I was trying to move the component or the parts of the slab. After watching your demo I realized I just needed to align the corners. Worked perfectly! Progress!

Thanks to you, of course. heritage_01.skp (2.7 MB)


#16

“Geometry” is what we have got used to calling all the actual “raw” 3D objects: faces and edges, as opposed to annotation objecta and object containers like groups or components.

Anssi


#17

OK. Now it’s time to address your use of layers. Here’s the Layers panel as it appears when I opened your latest (I’ve highlighted two columns, one in yellow, one in blue)

The yellow column controls which layer is associated with any new geometry you are drawing. And this shows an extremely common mistake: By drawing with the dot in a layer other than Layer0, you are associating new geometry with a layer that isn’t Layer0. By selecting other parts of your model, I see that you’ve also associated geometry with the “Garage” and “Basement” layers - and I stopped checking there.

Edges and Faces should always be associated with Layer0! Control their visibility by combining them in grouping (groups or components), then associate the grouping as a whole to a layer. As long as you keep the selected “dot” in the yellow highlighted column above on “Layer0”, your raw geometry (edges and faces) will remain associated with Layer0.

Additionally, you still don’t have a lot of your geometry correctly grouped. Yes, you’ve associated raw geometry to named layers (a mistake), but layers are for visibility control ONLY - they don’t accomplish geometry isolation!

Now this may seem counterintuitive, but the way to “fix” your mistaken layer associations for raw geometry is to delete all your layers except Layer0 as follows:

  1. Put the dot in the yellow column in the Layers tool back on “Layer0”
  2. Highlight all the other layers by clicking on the word “Basement”, then while holding down the “shift” key, click on the word “lot”
  3. Click on the “minus” sign up top. Wait - this might be easier to show in a .gif:

Now, all your raw geometry will be associated with Layer0. You can now create layers for visibility only, group your geometry into various groups, then associate each group with the appropriate visibility layer.

Even with as small a model as yours, however, the creation of distinct groups will likely frustrate you as many of your parts that you might want to group are already merged to other parts. Even here, it’s probably better to start from scratch with the following workflow and only 1 layer: Layer0:

  1. Create a 3d “part” - like a slab, or the rain tank, or a set of walls.
  2. Select all raw geometry in the “part” you just drew, right click, and select either “Make Group” or “Make Component” - I prefer to use components as you can name them individually (and for other reasons that aren’t applicable here)

Repeat the above for each “part”. Notice I’ve said NOTHING about other layers yet!

Once you have all your parts created - and their geometry properly isolated in groupings, go to the layers tool and add layers you want to use - remember these are for visibility only!

Finally, one at a time, with the Entity tool open, select a “part” with a single click (a double click will “open” the part for editing), then using the pulldown for “layer” in the Entity panel, associate the part with the appropriate layer. Repeat for each part.


#18

One additional thing you might find helpful. I had lots of trouble until I learned it.

Immediately after you draw something, you can select all the (connected) geometry - edges and faces - by triple clicking on any part of it. Then tap the letter ‘g’ key to create and name a new component. Make sure the check box bottom left labelled 'Replace selection with component ’ is ticked.

And don’t leave any ‘loose’ geometry (not inside a component or group) in your model.


#19

Thank you for an incredibly detailed explanation sjdorst. After paying for the Sketchup School and watching several of the videos I think Sketchup is like learning Greek from an English teacher. The conventions in the program bare no similarity to other drawing or CAD based programs. With my first drawing I assumed that layers meant something in terms of construction. I expected to build my floors one at a time with only that floor visible and all items added to that floor. This now appears to be completely wrong. I’m not understanding why layers are only for visibility and not doing design work.

A basic question at this point is about the versions. I am a disabled senior trying to live on limited pensions so I could never afford the $695 cost of Sketchup. If I keep trying to learn the program with Sketchup Pro am I going to lose everything when I am forced back to using Make?


#20

No. Make and Pro use exactly the same file format and your models will work exactly the same. All you will lose are Layout, the solids tools, some export and import formats, and ability to create your own dynamic components.