Sketchup keeps creating hidden geometry errors

love sketchup but…
I keep having to redraw sections of my drawing.
hidden geometry keeps turning up on faces that were previously okay.

on a half completed drawing with c.85000 lines that suddenly has a gazillion new hidden geometry lines appear for no apparent reason it is a constant battle

is there a way to automatically re-snap all existing intersecting endpoints together, say when endpoints are within a distance of less than 0.1mm from each other
remove endpoint ‘blobs’ along an edge of a flat surface that sketchup creates after ‘fixing’ my drawing?

I would attach a few screenshots to illustrate but there does not seem to be this option on this forum!

I see you joined the forum 24 minutes ago. Post e few more times and you should be able to attach screenshots and/or your model.

Do you have more than one (Layer0) layers and a fe turned off?
What is your active layer when modeling (should always be Layer0)

Post your model for accurate answers.

There’s probably a good reason once we see the model and know what you did in the few steps prior to when the issue occured.

thanks for the very prompt reply,

I have only one layer in use, a newbie mistake perhaps
I haven’t any repeated components either,
it’s just been a straightforward drawing, a digital line drawing on digital paper!

I can imagine that errors are sometimes caused by pull/pull intersections not snapping properly or at least I’ve clicked the final position when the guide point has disappeared ~ easy to do with push/pull, not quite as easy with the line tool as it has a measurement tooltip to confirm it’s length etc.

however, I have some round windows extruded from a flat face that suddenly have hidden geometry lines on the flat face from the round ‘corner’ points to the edges of the flat plane that the circle was drawn on… most go to the corners of the flat plane but some go to the edges

I have also copied and pasted flat faces rather than always using push/pull,
(zooming right in on corners for the best possible positioning etc.

I have the drawing set to two decimal places in mm (using model info). (my screen resolution is 1920x1080).
it’s hard to see any errors ~ other than the really obvious misplaced lines/faces etc where an existing line may appear bold after a paste. or an intersecting blob does not appear.

these appear after saving and choosing fix my drawing

am i right in guessing there is no quick fix tool available?

Quick fix for what? We need to know what is causing your problem.
Attach the model so someone can check it.

A few screenshots or even better, a model would really help. Can’t you attach anything yet.
As for a simple fix, you might be better off learning the cause and how to (if possible) avoid it from happening. There even miight be a simple fix but I’m still not sure what happened. Is this issue due to small geometry? Or rushing in clicking without waiting for the inference to show first?

This can be a sign that the rounds are not quite coplanar with the surface or not quite planar themselves. Just a tiny misalignment can cause SketchUp to triangulate the surface surrounding the round.

still unable to attach anything,

from my limited experience, I’m guessing the endpoints are not intersecting ~ example: three separate flat faces instead of a neat corner to a cube etc.

I have tried to us the ‘inference’ cues, but can imagine the displacements occur as I release the mouse-button.
it’s hard to rule out if the mouse is moving between seeing the inference cue and releasing the button.
I use photoshop a lot with no problems, but accept positioning in 3D is a different mindset.
as I said above I do zoom in on corners and drop-points etc where the inference cue is not forthcoming.,

only one image allowed at a time!!

i’ll stop there for the mo,
all the above areas were problem free.
now deleting the hidden geometry lines deletes the faces,
they are everywhere,
I am getting the feeling I might have to start again =:(

when using the arc or circle tool it is obvious that it is aligned to the axis, red/green/blue etc and black if not aligned.
I don’t think this was the problem.
also the ‘on edge’ or ‘on face’ tooltip is always gained before drawing.
I’ve also been using whole ‘mm’ too and can see when the ‘~’ symbol appears.

(Now you are able to attach images, you should be able to attach the model too…)

Have you used the move tool for parts of the model lately?

you should be able to attach the model

I’m sorry I cannot release the entire drawing just yet, once complete it will be released.

used the move tool for parts of the model

only with copy and paste, and using the push/pull tool (as explained above)

has anyone else had this problem ? (see images)

Tone, I had the same problem a few weeks back.

My was caused by two surfaces that were not totally 100% align.

One of my surface was out by 1/100,000 of mm. Every time I try to join the two surfaces together it would add 100s of hidden geometry lines.

You may have to check the alignment (X,Y,Z) valves of the surface to found the error.