Gray Lines that can not be selected or deleted

I have just started using Sketchup. I created a window and did an offset. I used push/pull and it snapped to something. I retraced the lines and I moved the wall out of the way where the windows were, and now there is a floating rectangle which I can not select or delete. I also tried retracing all lines, push/pulled all services, used the select arrow tool and highlighted the whole object and it still wouldnt delete. I rotated the view to select from a different angle (and not impact anything else, still nothing). Also, I cant find the object in the object tray.

What am I doing wrong.

You’re still inside another active group/component. Keep hitting escape until everything is normal contrast, and you should be good. When editing a group or component, SU dims down the rest of the model to help you visualize what you’re editing.

I tried doing that and also tried selecting out of it. I saved the file and opened this morning with fresh eyes and still wouldnt do it. But finally, I was able to select. Not sure what happened, but thanks so much for your quick reply.