What version of OpenGL is supported on GeForce 9600 GT, and what is latest Win7 driver for it?


#1

SU 2017 won’t run on my older desktop with outdated nVidia drivers. I’m just downloading the latest I can find on nVidia UK website - v376.33.

I can’t see on the nVidia website what OpenGL version this driver supports, and am not even sure if the hardware CAN support a recent enough version of OpenGL.

Google was unhelpful in answering this question.

Does anyone here know if this card CAN run SU 2017? It’s fine with its current driver on 2016, but definitely NOT happy for 2017 - OpenGL support is only for v2.1.

PS. The installer just finished downloading, and when run, says it cannot find compatible hardware! Odd, because I’m sure this card was listed on the download page as supported by this driver. Will look again at that.

Hmmm. I might have downloaded the wrong version. Will try again - but its a big download, and coming slowly, although I have a fast broadband connection.

PPS. Downloaded GeForce Experience to check the card and latest driver. IT says the latest for my card is 342.01, and has successfully installed it.

Now to see if it works with SU 2017…


#2

Good luck.Is this on a PC?


#3

Yes, my old main PC - not much used since I got an iMac just over a year ago, but still solid. Want to keep it if poss to check compatibility of plugin Angular Dimension 2. I suggested improvements to Steve Baumgartner back in the summer. I worked out how to display the dimension in the plane of the angle, with a BIG help from him in providing a transformation matrix to move it from where it’s drawn at the origin, to the vertex you are dimensioning.

He’s borne the brunt of developing the WebDialog interface for its parameters, which was a bit of a nightmare for both of us.

I started it, and thought I had it working, but alas, no. It fell over in several different ways! And didn’t remember the settings from one SU session to another.

FAR too difficult, in my view. Not sure if HTML Dialog will be any better in handling complexities of asynchronous communication, though it should avoid most of the conversion to/from strings inside single and double quotes, and locale differences in comma or dot decimal separator. JavaScript ignores the comma and always uses dot internally, and can’t detect the user setting, Ruby can detect the user setting, but handles it differently in lengths vs floats, and getting them to talk to each other without getting very muddled was hard work.


#4

Did you try installing CheckUp?


#5

No, I didn’t install Checkup. But I did install the latest available driver for my card. Didn’t work before restart.

And I’ve just restarted the PC, and it still says SU 2017 won’t run. Looks as if I’m out of luck for that.

And Windows running under Parallels only supports OpenGL v2.1, apparently the same as my PC before updating the driver. Not sure what the newer driver supports, but it clearly isn’t 3.0 or better.


#6

Hmmm… Might be worth installing CheckUp just to see.


#7

Might do later, but not tonight - well after midnight here, and I’m off to bed.


#8

Good night.


#9

Looks like you are out of luck where it comes to v2017.


#10

Thanks. Looks like v 2.1 is as good as it gets.


#11

… or maybe not? Wikipedia says that although this card was first introduced in 2008, it can support OpenGL 3.3.

I’ll get in touch with nVidia support to see if there IS a later OpenGL version available.

But maybe Wikipedia is just wrong.


#12

There are test programs which will report the info to you. Starting with Khronous group maybe best start point? I no longer have link to their test program but , search for OpenGL should be about 1st to show.


#13

With my Nvidia card you can right click on the desktop anywhere to open a menu that includes an option for Nvidia. Click on the option and go to the 3D section. Set it to use the graphics card hardware; both my PC and laptop were set to a default that avoids the card. Once set properly everything works great!
The guys at Sketchup helped me set this properly. Why this is not made public information, I don’t understand.


#14

I’ll look out for the Khronous program and see what it reports.

My machine is a desktop. It only has the one graphics card.

Thanks for both suggestions.


#15

I’m saying that the setting avoids using the graphics card acceleration to process (at least that’s my layman understanding). Apparently the default setting was created to reduce power consumption. Makes sense on a laptop but why it was the default on my monster sized graphics card that would never fit in a laptop is beyond me.


#16

What you are missing is the discussion relates to SU2017 which provides no option to disable Hardware Acceleration.


#17

This is a setting in the card Driver software. It has nothing to do with Sketchup settings.


#18

SketchUp 2017 only uses the graphics card for display. It won’t use the CPU like older versions can.


#19

Yes. The setting in the driver software being incorrect makes even more sense to me now that you tell me Sketchup cannot turn off “use hardware acceleration”. I couldn’t even get Sketchup 2017 to open when the setting was wrong. Had I known this Nvidia setting was improper I would have changed it years ago! Maybe a public announcement to the community is a good idea.


#20

It was announced in the release notes and elsewhere.

[quote]
Graphics Pipeline
With SketchUp 2017, we have completely reworked our graphics pipeline - i.e., the way we display SketchUp models. This was a massive change that will allow us to innovate far beyond what we have been able to do in the past.

This new graphics pipeline has stricter hardware and software requirements than in previous versions of SketchUp. To run SketchUp, you will need:

  • A 64-bit operating system.
  • A graphics card that supports OpenGL 3.0 or above.
  • A graphics card that supports Hardware Acceleration. We will no longer support software rendering!
  • A graphics card that passes a series of tests that are run by SketchUp 2017 to assure that your card is capable of rendering SketchUp models. These tests include checks like compilation of SketchUp’s GLSL shaders and support for OpenGL framebuffer objects.
    If your machine does not meet these requirements, you will see an error dialog when launching SketchUp, LayOut, Style Builder, and Viewer that lets you know which requirement you did not meet and which will prevent you from running SketchUp until you fix the error. If you see this error dialog, try upgrading your graphics card driver - upgrading your driver is a good first troubleshooting step and often solves the error.[/quote]