SketchUp 2017 requires a graphics card that supports OpenGL 3.0 or better

hello!
I get the error message from SketchUp Make that my graphics card/drive does not support opengl 3.0.

But I was modeling with 2017 on 19 november fine!

How is that possible?

How can I fix? I already tried a driver update, but I seem to have the latest!

Do you have another graphics card installed? SU may have been using that when it was working, and somehow got reset to using the built-in graphics, which aren’t up to running the latest version of SU.

If that might be the case, you need to find how to set SU to use your other graphics card - I know you can, but don’t know how in detail.

1 Like

Nope. Only one graphics card… Thanks for the reply!

Then I don’t know why. Sorry. Possibly reverting to an older driver might make it work again.

Are you sure it was v 2017 you did have working? Not an older version which CAN run without hardware acceleration or with a lower version of OpenGL?

if your on a laptop, check your battery saving mode doesn’t downgrade the graphic card…

I have no idea ‘how to’ on a Windows PC…

john

We need more specs about your Intel graphics to find out if you do indeed have the latest driver.

Open the Device manager. Go to the Start menu. Either open it through the Control Panel or search for it. Once there, go to the Display adapters > r-click on your graphics card > Properties > Driver. What is your info about card and driver?

I checked the power saving setting and they are on full performance.

Here the driver details…

The first thing you should try is to update your graphics driver. As shown in your screenshot, it is exactly four years old today. Go to the Intel website and look for the latest available one for your chipset.

Anssi

First thing I tried. I got the latest. As I mentioned in my initial post.

Thanks for your reaction!

I solved it by buying a new laptop. Long overdue anyway…

And when I opened the model I created earlier, it turns out I was using 2016 after all. My bad. Sorry for the confusion!
:grin:

Hi, My graphics card doesn’t support windows 10 no driver for the NVS 300. Ihave a new GeForce GTX 1060 however I need a new power supply to run it the tower is a Dell Precision T1650. Any ideas anyone?

the ‘Corsair’ and ‘be Quiet!’ models do regularly get good reviews, the modular versions will allow you to connect the required cables only = less mess in the case.

Thanks for your reply sketch3d_de. I truly don’t know what I’d do without the forum’s help.

I had same problem and solution is very simple at least for me.

  1. open nvidia control panel > select “manage 3d settings”
  2. under “program settings” tab select sketchup
  3. select your nvidia graphics card under “preferred graphics processor” instead of the default “auto-select”
    That’s it.

I had the same problem, but I have 2 graphic cards on my pc and two displays. When I tried to start SU it told me the same. I’ve tried to update drivers, then change default graphic card…

The last thing was working, but only with one display, But I was needed second one two.

Then I got a great idea. I went to win display settings and set my AMD card as first display.

The problem was solved!!! Thank ya all for your messages!

Thanks for your answer. It’s exactly my case. I have a new gaming laptop with an integrated graphic card (Intel 530) and a dedicated graphic card (nVidia GeForce GTX 965M) but suddenly SU don’t recognize my nVidia card and say that my Intel don’t support OpenGL. I try to find out how to set SU to use my other graphic card but couldn’t find an answer. I’ll keep looking.

Eldad

I have the same problem, my grahic card Intel HD graphics 4000 is not able to work with SU 2017 or 2018.
Can U recommend a laptop that is compatible with SU 2018?