SketchUp using Intel Integrated Graphics and not Nvidia Dedicated

intel
nvidia
graphics
driver
control_panel

#1

Hello everyone.

So i bought a new laptop last year that has a built in Intel HD 530 Graphics card as well as an Nvidia 960M card. I have been using Sketchup without any lag or performance issues for a while. However, as my project is now larger my computer is starting to get sluggish. I checked to see what video card Sketchup is using and it says the Intel 530 graphics card. I went into the nvidia control panel and into the 3D settings and assigned the Nvidia graphics card to Sketchup. I then rebooted and in the Sketchup Open-GL preferences it still says i am using the Intel graphics card. I tried changing to all possible settings in the Nvidia control panel but for some reason Sketchup keeps telling me that i am using the Intel card.

I have no idea what to do. I know that the Intel card is much slower than the Nvidia card and i know that i am most likely going to get a performance boost by getting Sketchup to run with the Nvidia card, but for the life of me i just cant seem to be able to assign the Nvidia card to Sketchup.

Does anyone have any experience with this problem or have any suggestions at all?

Thanks.


#2

I just force my notebook to use GTX globally


#3

I tried that in the Nvidia Control panel and it doesn’t work. Whether globally or application specific it just doesn’t work.


#4

Take a look at this thread and see if it helps.


#5

Interesting. It turns out i have that option but even when i select the Nvidia card it still registers as the Intel card in the openGL preferences dialog box in Sketchup. So it doesn’t seem that Sketchup is picking it up.

And im pretty sure that Sketchup is using the Intel card because i can only set the anti aliasing within sketchup to 4x. With the Nvidia card it should go to 8x or even 16x.

Also, if i disable my Intel Card then it shows up as the Nvidia card in Sketchup. But when i disable my Intel card i get all kinds of screen tearing issues.

I just cant figure out why this is happening.


#6

Is your Nvidia driver up to date?
Is your display set to Full colour?

Just random suggestions


#7

And of course the question, did you run the SketchUp installer “as administrator” ?


#8

Wow, it was the Nvidia Drivers!

How did i not think of that? I knew there was something sketchy about the settings in the Nvidia Control panel because it said “Google Sketchup” before i updated the drivers and now it says “Trimble Sketchup”. It’s not supposed to say “Google Sketchup” since i have Sketchup Version 2017 which is owned by “Trimble”.

Oh man it feels so good to actually seek a solution to a problem and to get it right on.

Thanks a lot Anssi. You made my day.


#9

cute :wink: [quote=“Moe, post:8, topic:45506”]
was something sketchy
[/quote]

by default we think of checking the basics, like updating driver…


#10

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.