SketchUp unable to detect Nvidia Graphic Card

Specs:
OS: Windows 10 64bit OS
Graphic Card: Nvidia Geforce GTX1050
Processor: Intel® Core i7-7700 CPU @ 3.60GHz
Ram: 24GB

Hi,

I recently downloaded Sketchup 2019 into my pc. However, upon opening it (with & without admins), I received a warning message:

The following warnings were found when launching SketchUp:

  • SketchUp has detected your computer system has multiple graphics cards and is defaulting to an integrated Intel graphics card. SketchUp will perform better if you change your system to default to the AMD/NVIDIA card.

See this Help Center article for more information.

I tried the above article, but it did not work.
Did full uninstall of Nvidia Graphic card and a fresh installation.
I also tried using the nvidia control panel to overwrite the program settings of Sketchup’s GPUs & OpenGL rendering GPU, but still it does not work.

Currently, sketchup uses my Intel HD Graphic instead of Nvidia graphic card.

On another app (photoshop), when i open the performance, it stated that I am using Intel Graphics instead of my Nvidia Graphic card.

Does anyone have any experience with this problem or have any suggestions?

Thank you

There is, still I think, an issue with Windows 10 build 1903 when used with display docks. The dock ends up being given the Intel GPU instead of the Nvidia GPU.

You could try switching your monitors, or open SketchUp on a particular screen. Or, try going into Graphics Settings, and add SketchUp as a classic app, then use its Options to request that it uses the high performance GPU.

See this recent post (where I explain how to set apps to use a specific GPU on Win10) …

Do you use a ’hub’? Make sure the monitor is in the right port, i.e. the one of the card, not the motherboard

Hi, I did the steps above.

When I try to open sketchup 2019. The window below appeared.

image

Sorry, may I know what is a ‘hub’?
Does it mean the monitor cable must be plugged into the graphic card?

You do not state what type of device you are using, a tablet, a laptop or a desktop. Knowing this info will help us to get you up and running.

1 Like

I am using a desktop.

It is connected to my nvidia graphic card via hdmi

What version of the driver?
Rightclick on an empty spot of the desktop, choose ‘Nvidia-settings’ and then in the left bottom corner of the panel, choose ‘System information

Go to This page and get DDU (free) Study the directions in the post.
Detailed DUD instructions

1 Like

So explain a bit more. This was to remove all drivers and have Windows reinstall a basic Nvidia driver on reboot ?

1 Like

OUCH!
The only Nvidia drivers that work anything like reliably with SketchUp are those downloaded and installed from the Nvidia website.

DUU will remove drivers from the big three one driver at a time, need to run (possibly) three times. Prior to running DDU one needs to DL the driver of choice to install after the removal.

1 Like

You might have to go into the BIOS and turn off the integrated Intel graphics. Reboot your computer and everything will only see your Nvidia graphics card.

Why does a user need to jump though hoops to make Sketchup use the correct graphics hardware installed on the computer? Autodesk does not to have a problem identifying the type of graphics hardware and notifies if hardware acceleration is OFF or ON. If the Sketchup developers want to keep up with the competition then perhaps more focus should be on this subject.

You’ve got it mixed up a bit. It is the computer (OS) needs to be told which GPU to use when running SketchUp.

AutoDesk (and other major graphics software) products are in the default configuration files for GPU OEM’s control utilities. Many users have asked these OEMs (Nvidia and AMD/ATI) to add SketchUp but it hasn’t happen yet AFAIK.

So on MS Windows the OS just tries to load SketchUp and LayOut using the integrated Intel graphics. The fault mostly lies with MS Windows, IMO.

1 Like

Last time (about 2 years ago) I installed SketchUp on a computer with Radeon graphics (AMD) the driver had SketchUp added as default. I still prefer Nvidia, though, even if I have to go to the 3D application settings to set it up.

1 Like

okay, I now know we’re half way there. Thanx.

And I also do not find it all that difficult myself to tell either Windows or Nvidia Control Panel what GPU to use for certain applications.