Sketchup 2021 is defaulting to integrated Intel graphics card

Hey, I’ve just recently started having this issue. I’m not sure what the cause is. I’ve updated the drivers on my Nvidia card and windows 10 is up to date.

My setup is an acer aspire 7 laptop which is connected to 2 external displays.

If I open SketchUp 2021 on the laptop display SketchUp appears to use the Nvidia GPU but if I close the lid and open SketchUp I get the error message that its defaulting to the Intel GPU

I have tried selecting the GPU in the Nvidia control panel to force SketchUp to use the Nvidia GPU but that didn’t work.

Any help would be greatly appreciated.
Thanks

hello, this might be a (clever) protection from your laptop, to prevent it from overheating.
Laptops are (also) getting cool air from the keyboard holes, closing your lid will stop this from happening ; it may then switch from your graphic card to the integrated chipset to avoid overheating.

If you still want to go around this, you may want to check in your power management settings for action to be done when the lid is closed, or restart windows with the lid closed

1 Like

Maybe thats the case, Ill give it a try. But I find it hard to believe this is the problem since I was running 2019, 2020, 2021 with my laptop closed and using my 2 external displays.

Windows updates can screw things up.
Sometimes, repairing the installation works.
Download or look for the installer (always keep a copy somewhere)
Close all instances of SketchUp, LayOut and StyleBuilder.
Rightclick on it and choose ‘Run as administrator’
Choose ‘repair’ when prompted.

So I think Ive fixed the issue. Under Display options at the bottom is listed "Multiple displays with a check box “make this my main display” Ive check that and now its working fine. Windows had updated recently maybe it had unselected that box? Either way. issue is resolved.

Windows updates commonly change things like that. It’s a good idea to keep an eye open after the next update.