Sketchup defaulting to onboard GPU

I run an MSI laptop with an Nvidia RTX 2070 Super graphics card in it. However, Sketchup only recognizes the onboard intel card. I’ve tried changing the Graphics Performance Preference to High Perforamance in Windows Graphics Settings, I’ve changed the Program Settings in the Nvidia Controller to no avail. After opening Sketchup and checking the preferences and Graphics Card Details it tells: SketchUp has detected your computer system has multiple graphics cards and is defaulting to an integrated Intel graphics card. SketchUp will perform better if you change your system to default to the NVIDIA card.

This is driving me crazy. Paid for a great graphics card, but sketchup wont use it and lags like crazy in large models. Please help!

Have you tried setting it in the Nvidia Control Panel?

Are you using a dock to connect an external monitor? Some of these refuse to support the Nvidia graphics card or OpenGL. If you are, connecting the monitor directly to your laptop might help.
A more drastic thing to try might be disabling the onboard graphics altogether in Device Manager.

1 Like

Yeah, I changed it there as well as in the Windows Control

I do have an external monitor connected, however it is direct into the laptop, no dock. Sketchup behaves the same way when running only on the latptop too. I’ve tried to disable the onboard gpu with no luck either.

When you installed SketchUp did you right click on the downloaded installer and choose Run as administrator?

I don’t think. Could that make a difference?

Might make a difference. Correct installation on Windows requires that process. Close SketchUp, find the downloaded installer or download it again from sketchup.com/download/all Right click on it, choose Run as administrator and then if prompted, choose Repair.

If nothing else it won’t hurt.

So I just tried that and got Error 1321 - Insufficient privlages to modify …\Sketchup2021\libGLESv2.dll

Try a cold reboot of the computer and then try the installation. Is there some sort of IT department lockdown on the computer?

No there shouldn’t be any kind of lockdown on it. It allowed me to ignore the error and continue the install and Sketchup works, but perhaps this has something to do with the GPU?

It might. Have you tried updating the graphics drivers from Nvidia?

Solved it! When uninstalling, it never did a complete uninstall and left libGLESv2.dll in the folder and wouldn’t let it install a clean copy. I deleted the entire folder after and uninstall and reinstalled. This fixed it, finally. Been working at it for months.

1 Like

Good deal. I guess I didn’t know that you had uninstalled and left something behind. Now you should be in good shape, I hope.