SU 2020 OS X Catalina: Is there a GPU driver for NVIDIA GeForce 8800 GT 512 MB?

I was sad to not have SU2020 on my MacPro (early 2008) due to it’s age. However, I was recently able to update the system to Catalina. But, with the NVIDIA GeForce 8800 GT 512 MB, I’m getting the error “- Hardware acceleration is unsupported or has been disabled on your “Apple Software Renderer” graphics card. SketchUp requires that you use a hardware accelerated graphics card.”

Has anyone successfully been able to get a driver or workaround for this? I’ve seen two other posts here that had this error message, but, there’s been no responses or none that gave an indication.

I’m so happy to be able to install SU2020 on my system… but, I can’t find online answers to this question about the error message and what to do about it.

Thanks in advance for the help… or the patience. :slight_smile:

I’m glad you mentioned this. I think I have two Mac cases and two Windows cases, where it is claimed that there is no hardware acceleration. I hadn’t thought about it being so old a Mac that it had Nvidia hardware in it.

Mac OS 10.12 was the last system that supported Nvidia. I don’t know if there is a work around to that.

1 Like

Were you really able to get a 2008 Mac updated to Catalina? Wow, that is impressive if true.

Apple used to have CUDA NVIDIA drivers floating around as recently as 3 years ago, but dropped them entirely more than a year ago. Your best bet is to use a new Mac, or one at least newer than 2008. I think anything after 2014 should be good with SketchUp 2020, but that’s just a guess.

1 Like

Yeah, as soon as I get back to my old system and come across the link to do it, I’ll share it with you.

I’m trying to avoid moving to Catalina for as long as possible. I want the last best machine to run Mojove for as long as it can hold out.

1 Like

The last “official” version on my MacPro that worked was El Capitan and I was happy with it. But, I lost the HD and needed to install something that worked. However, I will put in a new HD and install Capitan again. Catalina refuses to recognise my second screen and though there’s new stuff to appreciate… I can’t live without a second screen. So, currently, I’m running Yosemite 10.10.5 from an exterior HD system disc and needing to update it to Capitan on the new HD when installed.

I don’t think you installed Catalina on your 2008 Mac Pro. It’s not compatible with that hardware, as indicated by Apple’s own list. https://support.apple.com/en-us/HT210222 ; According to Apple, your Mac Pro must be 2013 or newer to work with Catalina, which was my guess all along.

Not sure what to reply to that… except, “If you think and say so.”

But, one must also think, “If he didn’t install Catalina on his Mac Pro, why would he come to this forum (wasting his time and ours) to create a fabricated post about drivers for the impossible?”

Regardless, I can’t argue with your logic.

But, my Mac Pro (Early 2008) seems unwilling to respectfully consider one’s thoughts as conclusive evidence of the impossible. It stubbornly refutes the doubt and, in defence of me keeping my wits enough to know what I’ve installed, what I’m posting about and why, it offers this:

Screenshot 2020-08-23 at 08.15.20

Macs can be so stubborn that way.

It may not have been the wisest decision, as there are complications with Catalina that I’m discovering (such as not recognising my second screen and SketchUp not working due to acceleration GPU issues)… so, there’s no reason to pursue this further unless directly related to finding solutions for the driver situation. However, If there are no solutions available, I still won’t consider this a waste of time in asking.

Simply, I think the gear is so old, I’ve painted myself into a corner I can’t get out of…yet.

Thank you though for participating.

I’m seriously thinking of erasing the drive and reinstalling El Capitan. Painful, but, so far, I’m not convinced I’ve “gained” anything in Catalina that outweighs all I’ve lost in the upgrade. Thing is… yes, it offers stuff that’s new that I don’t need… but, I’ve lost so much of what I do need (use of second monitor and ability to use the GPU for SketchUp and therefore, rendering with Thea Render). I haven’t even had the chance to discover the features of Catalina… as all of my time with it has been trying to solve these issues.

So far, I think it might have been very wise to have stayed with the old system (10.11.6) that was working, even if it wouldn’t work with SU2020.

Unfortunately, I lost that drive and so, in trying to get the info back, thought to do this “upgrade”. And we can’t downgrade once it’s done. Pretty much, complications everywhere. Keep the Mojave up and running as long as possible… is what I’m thinking today.

Did you upgrade through a normal process or did you use a workaround?

A workaround I was going to share. But, on second thought, there’s no reason to share how I did it as it so far has rendered my SU versions useless and I don’t want to trip anyone else up into making the same decision as I made (which so far has turned out to be a mistake).

That’s what I figured. If you had tried to upgrade to Catalina through Apple, it would not have been allowed because your hardware is not supported and problems were guaranteed. The workaround itself even warns against using it for this very reason, pretty much indicating that attempting to update a computer not on Apple’s supported hardware list is at your risk and is most certainly going to cause major issues. It even tells you to back up your data for this is expected to happen.

I can’t tell what you are crusading here. Sorry.

Let’s start over with “Early 2008”. That means the computer is 12 years old!
I lost the system HD that had El Capitan 10.11.6. Even as is, it’s so old that SU2020 won’t work.
I damaged nothing in trying, since the HD was lost anyway.
And since I had a backup of data, giving it a try was a valid option.
Catalina worked.
I just can’t get the drivers. Voila.

But, for some reason, I sense you are simply trying to rub my nose in it and not sure why.
First, telling me you think I didn’t install Catalina (more than a little presumptuous) and now telling me I couldn’t via Apple (pointing out the obvious?!)

So, yeah… you’re right to an extent. Apple would not, could not update this old grandpa of a machine, if that’s your whole point. That’s neither relevant to this nor new information to me. I’ve been an Apple user since the early '80s with the Apple II. I wouldn’t screw with anything unless it was “safe” to do so.

But, whatever risk you are campaigning was null when I had lost the system in the first place… A GREAT TIME to try something unconventional. I think you’d possibly agree to these circumstances for trying something new. I’m quite sure that Catalina on my old machine is excellent if I just wasn’t a SketchUp user. So, in that regard, I can’t agree with you fully. Catalina was running and working… just not on the software I wanted it to work with.

And IF it had worked, there could have been a new solution for me to run SU.

So, if you couldn’t trust that I “did” install Catalina, at least try to trust me when I say that “no harm” was done in this experiment.

Furthermore, for your information, I have two systems installed. The option between the two is presented on Mac startup when holding the ALT key. For this reason, I can go to the Catalina system or choose the Yosemite (which I’m using at the moment). Since losing the original El Capitan system HD, it’s Yosemite I need to upgrade back to 10.11.6.

So, don’t fret too much. My gear is protected and my MacPro 2008 is still working just fine.

Thanks for trying to help though.

1 Like

I got the impression that your hack of installing Catalina on unsupported hardware wasn’t benign, and instead disabled your video card and any peripherals attached to it. I was only trying to say that was probably a result of installing the update on hardware it clearly doesn’t support. That is all.

Colin, you bring up an interesting point I didn’t pick up the first time.

I’ve been updating my OS X up to 10.11.6 and everything worked with the Nvidia card. The system became too old for SU 2020… but, SU2019 was still working with the NVIDIA GeForce 8800 GT 512.

How old are your two Mac cases? Are they PowerPC Macs like the G3 or Power Mac G5 duel or quads? I have a couple of those collecting dust but, can’t imagine trying to even see if anything works anymore on them. Surely it won’t. Not even sure why I keep them except that I just never wanted to get rid of my old gear for some reason. :slight_smile:

Old habits are hard to break.

Well, as I mentioned, Catalina does not recognise the second monitor. And after doing online searches, discovered there are many a user having the same issue and waiting for a fix from apple for that, even with new mac models. As far as peripherals are concerned, the system still accessed all other internal and external devices and HD connected. To be honest, I can’t see the disadvantage of having Catalina installed for discovering what else works and doesn’t… as long as I have my heritage system running on the machine as well.

Simply, Catalina does not support the Nvidia cards and has acceleration issues. Now confirmed. Not sure what else that may entail, but it renders SU unusable.

I seemed to have made a typo in that reply. 10.2 would have been five years before your computer was released. I did mean 10.12.

While double checking that I found this web page, that has Nvidia drivers for 10.13:

If that really worked, you would be able to run 2020 in 10.13, on Nvidia.

1 Like

Dang!!!

Now you KNOW I’m going to have to try High Sierra on the old girl (MacPro) to just “see” if it works.
Yes, Ben… this would mean a workaround since Apple can’t upgrade.

But, IF it DOES work, Colin, do you think SU2020 would possible work? Do you think there’d be issues?

1 Like

10.13 is in the list of systems that should work. You will want to get up to 10.13.6, but it may work before then.

Now THAT, sir, sounds seriously encouraging!
Thank you so much, Colin. Much appreciated.