Hardware acceleration issues

We’ve had a number of reports, on Mac and Windows, where SketchUp 2020.2 shows a message saying that you don’t have hardware acceleration. It’s a difficult problem to work on, because most of the reports end up having an explanation, and it would be nice to find a case that can’t be fixed.

I’ll give some example cases, and if you match one of them, try the cure that has worked for others. Let me know which number it was, and whether it still shows the problem.

  1. Mac user, on a machine that previously ran at least 2017 ok. So far I’ve seen a couple of these, and for one a reinstall of SketchUp fixed the problem. For the other, the macOS version had been updated beyond 10.12, and the Mac had an Nvidia GPU, which Apple don’t really support after 10.12. The update is likely to be what introduced the new issue.

  2. New Mac that has never run SketchUp. We do have a bug report open about this, but please let me know if that’s your situation.

  3. Windows computer that has only one GPU, and it’s what should be a capable Intel GPU. Try a test page like this one:

What score do you get? At the moment I have a lot of demanding applications open, and even so get around 800 on my MacBook Pro. One customer getting the hardware acceleration error scored 140. If you get a low score, something in your system needs fixing. Try SketchUp again when you get a better score on that page.

  1. You have two GPUs, an Intel one, and a second AMD or Nvidia one. If you are seeing the hardware acceleration error, does going into Windows hardware settings and disabling the Intel GPU fix the problem? Note that this test should be done running SketchUp locally. Running SketchUp on RDP can lead to the same symptom.

I will edit this later if I remember other variations!

You’re showing off now! I did do a test with Safari set to use WebGL 2.0, and got 1200. Later on I will close all other apps, and see if I can beat that.

What should I have gotten? That was with a YouTube video running on the other display.

I was teasing. You could try again later when only Chrome is open. But this is just for reference, hopefully some people will come here with the hardware acceleration issue, and your figures will help them to know what to expect they should get.

My network doesn’t have enough stable bandwidth, I couldn’t complete that test :flushed:

Does everyone get shown a map of Helsinki (Finland) in the SVG graphic test?
OK-reading further, Basemark is a Finnish company…

I will try to find a test that is only WebGL, and not all Web 3.0 features.

You never said how long the test would take !

I feel terribly inadequate !

I’ll try Chrome next…
It is an old PC / GC !

A bit better with Chrome…


But still woeful !
:face_with_raised_eyebrow:

There is a thing on the page that says 3-20 minutes, but I was being hopeful.

Can any of you find a page that only tests WebGL, that gives a performance figure?

It was screaming along and then reported that several tests couldn’t be completed because my network was unstable. Due to this it wouldn’t calculate a final score. Network instability is a common issue at my Summer place where we have only slow DSL that can be overloaded if any two things try to use it at the same time (there are two computers and two phones all competing for attention!).

Yes, I ran into that too.

If I can find a simpler test page I will modify my original post, and then delete all of your replies!

I came up with a score of 533. This is in Firefox with an Intel I7 8700k with Intel 630 graphics. This is my backup PC.

271.08 on my Pixel C tablet, Android 8.1.0 using Chrome 85.0.4183.101.

I consider myself impressed. It’s not a great score out of context, but for an old tablet, it’s pretty darned good!

I got a network too unstable message which may explain the failure of the WebGL test.