VR Viewer Login Problems

Hi everybody,

I’m having a similar problem to that reported multiple times throughout the forum in regards to successfully logging into the Sketchup Viewer VR app on my Oculus Rift. Specifically, I have the exact same problem as UnopenedParachute posted on Feb 16th here: VR Viewer Installation Problems

I have a current subscription to Sketchup Pro. I have downloaded and installed 1) the SketchUp Viewer VR for Oculus; and 2) downloaded the Sketchup Viewer AR/VR Extension. Both of those seem to be available and doing roughly what they’re supposed to do in terms of booting up / exporting files etc.

However, when I start the Sketchup Viewer VR for Oculus on my VR headset, the first thing it asks me to do is log in. When I select the option to log in, it kicks me out to a web browser. When I lift the headset and enter my login details on the web browser, it logs me into my Trimble account. However, at this point the server sends back a webpage that the browser doesn’t know how to deal with - I presume it’s a license response.

On Chrome it tries to open Windpws Explorer, which results in a webpage directed to localhost, but then complains that it can’t access the webpage.

On Firefox I can choose the application that should handle the response file. I’ve tried Windows Explorer, with the same result as Chrome. I’ve tried the Sketchup Viewer VR executable, but literally nothing happens. I’ve tried the main Sketchup Pro executable, which does open the application, but doesn’t know what to do with the link. I’ve even tried the sketchup_authenticator.exe within the Sketchup Pro 2019 folder. Again, nothing happens.

I’ve also tried turning off all firewalls and anti-virus while going through this authentication procedure.

Does anybody have any advice? Thanks in advance.

1 Like

SO - just curious did you ever get this resolved?

I’m experiencing this same issue so I’m also interested if you found a solution.

I have seen this before and forgot what I did about it at the time. I’m testing again, and something to notice is that the problem happens with an ordinary sign in, long before I connect a headset or run the SketchUp app.

I relived the combination that worked for me:

I signed into sketchup.com, then signed out again. Ran the SketchUp app from inside the headset, and did the sign in. Then the launch of Windows Explorer succeeded.

I found the culprit in my case. It was postgres database using port 5432, the same port VR viewer was trying to bind to. I had to disable the postgres service and then it worked nicely.

If, unlike me, you really need to use postgres you should change the port it uses to other than 5432.

This topic was automatically closed after 183 days. New replies are no longer allowed.