Sketchup Viewer VR log in issues with Oculus

Just installed Sketchup Viewer VR. I turn on the headset (Oculus) and see the app- I open it and it says I must log in- go back to browser. When I log in on the browser- it freezes and stays there. I am currently on the Pro 30 day trial version with 14 days left in my trial. I’ve looked online and it seems peoples previous similar issues were related to their version- but I have the latest Pro trial version, so that shouldn’t be the problem. Please help! Thanks ahead of time!

What has worked for me is to open your browser on your PC, sign into, sign out again, then go through the sign in on the headset. It will tell you to continue on your PC, like you had tried to do previously, but now when you sign in the headset should get through to the next step.

Have you checked if you have any software using port 5432? I had postgres installed wich uses that port.

You can check that in Resource Monitor, Network Tab, Listening Ports.

You can also paste this in Powershell and should tell you if and what you have something runing on 5432.
Get-Process | Where-Object -Property Id -eq (Get-NetTCPConnection -LocalPort 5432 | Select-Object -First 1 -ExpandProperty OwningProcess)