Can't login to Sketchup VR

Good morning. I’ve got the Sketchup for VR app and extension installed. When I launch it via Virtual Desktop (Quest 2) it pops up saying to sign into my account. When I click the button, a dead website pops up on my computers browser?

At the end of the signing in the browser then has to launch a particular Windows task. Also, at the start of the sign in the web page is showing a localhost server.

Both of those things can go wrong if your default browser is IE or an older version of Edge. Try setting the default browser to Chrome or a newer version of Edge.

Thanks for the quick reply. This is in the latest version of Chrome. I’ll try it in Edge

Part of the issue with the signing in part is that the address can be interpreted as being an Intranet address. See if this article helps:

Something you can try too is to edit the URL you are given, and replace just the ‘’ part with ‘localhost’

Well…! I got further in Edge lol Desktop 2020.11.28 -|video

What app has an icon with VR in a blue circle?

Try Chrome again, with the edit to make it be localhost.

Steam VR which launches automatically when I open Sketchup VR

Tried Chrome again after Edge and followed your link instructions. Still the same results. I closed Chrome completely and it does the same thing as Edge. Lets me login, but then fails on the next page

Just tried Oculus Link (hardwired) as apposed to Virtual Desktop (wireless) with the same results

I have never tried with only Virtual Desktop. What is the performance of the Rift Home Screen like?

I tried to get my Quest 2 to fail, by setting IE as the browser, but for me it still worked.

The last thing the sign in tries to do is to take you back to the viewer app. What happens if you manually go there after signing in?

Another thing to try, go to and sign out, before you attempt the VR sign in. I think there can be an issue if you try to sign in when you were already signed in.

When I go back to the headset it just repeats and keeps trying to bring up the website. I tried signing out of sketchup with the same results. The performance on both VD and Link are flawless. I plan on heading into the office shortly to get this all set up there. Hopefully it’s just a weird issue on my home PC. I primarily want to get this working for clients in our conference room.

Quite a bit of time later, I know what the VR icon is. I now have Side Quest and Virtual Desktop setup. It works better for me wireless than the Oculus software via Link cable.

One problem I had was selecting things in within the SketchUp Viewer app, and in Steam VR in general. I would have to frantically click on things many times. My guess is that the movement of the line while I am clicking make it seem like an invalid click.

Even with those problems I was able to sign out or sign in. I did find that Chrome does better than IE after the sign in stage.

Have you tried running with only the Oculus app and Link cable (no Side Quest or Virtual Desktop)? Make sure the Quest 2 is a device that looks connected in the Oculus app, and then open SketchUp Viewer, either on your PC or from inside the headset.

Just thought of something else to check. What email address were you signing in on? Hopefully it was your mecaengineering, and not either your Facebook or Steam emails (if those are different).

Well it apparently its something funky with my home computer. I tried on an office computer with no problems at all. At least its working where it needs to be working lol

I finally had a few to mess around with Sketchup VR in a smooth environment after replacing a graphics card. Man I really hope you all fine-tune the controls for it. It is the furthest thing from being intuitive from the standpoint of moving around (get a gamer hired/contracted… lol).

Highlight something with the right hand and have to click/activate with the left hand. Use your right hand to highlight, yet it would randomly adjust/move the model. This has so much potential (and its all smooth, even on this relatively old GPU for testing [GTX 1650 4GB]) and I will enjoy showing it off tomorrow but I can already see the headaches just from our engineers (not even the clients) trying to just navigate around. And what’s up with that floating settings window? You hit the “X” and it just continues to pop up like a fly you want to swat lol

Sentio VR felt like it had the controls nailed down but it has always been flaky on loading models of various sizes. You can either float around veeeeery slowly or use the other stick to “jump” to specific areas. But they were/are also horrible at understanding “floors” to keep you in line with eye-height as you move around. That aspect was GREAT in SU VR. Pleeeease keep improving this. Especially with the Quest 2 release and the quality it has at that cheap of cost. We are definitely considering buying a few of them in the near future.

I have a similar issue trying to connect to SUVR with an oculus 2 and am unable to get past the browser login step.

I’ve tried the suggestions here and in other posts with no luck and have had a remote session with SU General Support last week, which was also unsuccessful. The ticket has been escalated to the technical team but I was advised to ask here in case there was any other ideas that might help in the meantime. If you have any ideas please let me know.

Thing’s I’ve tried (not in order):

  • Changed default browser to Chrome, Edge, Mozilla
  • Tethered 4G iphone connection - the PC is normally connected by ethernet to fibre broadband/router
  • Changed to localhost
  • Changed SUVR app to compatibility mode (Win7&8+Administrator)
  • Tried SUVR Installer & Oculus Viewer Applications
  • Checked port 5432 is free
  • Signed out of SketchUp Pro,, SU Forum & 3DWH
  • Disabled windows virus & firewall protection and 3rd party antivirus software and chrome adblocker

Each I sign out of before launching SU VR then receive the login error page after signing back in.

Note: I now have 2 ‘Trimble’ accounts associated with my account since I migrated from Classic to Subscription – is this a problem?

Win10 Pro Desktop (up to date)
SU 21.1.332
Oculus 2 with Rift Cable / Air Link connections (No issues with other applications)

@colin do you have any other ideas I could try??

For information i managed to resolve the issue eventually.

It turns out the port 5432 was being used by PostgreSQL, which i think was installed with Davinci Resolve. Stopping postgres in Services allowed me to login.

1 Like