Viewports resizing when updating Layout

Sometimes my viewports in Layout change size when I update the model. This usually happens to 3D viewports rather than 2D scale views. I can lock the viewport bu then that doesn’t allow me to update changes from Sketchup. Am I doing something wrong?

Do you have scenes set in SketchUp?
Are the viewports properly setup referencing the scenes in LayOut?

I am assuming that you dont refer to the actual viewport window changing size, but that the content is scaled.

Every time you update your scene in Sketchup you also update the camera position, if camera position is set (checked) to be saved to scene, in the scene “properties to save” list.

If that camera position is changed then the Layout viewport will also change accordingly.

2 ways to fix this:

  • Most people on the forum says: Make sure to not change camera position when updating the scene. You can update your scene without updating camera position, by using the update button on the scene panel, and unchecking camera position when updating.

  • Easy and safe way: Double click into the viewport in Layout, and then click outside it to exit editing the viewport. Your viewport will no longer respond to any changes to camera position in the scene, and only adhers to changes you make in Layout for the viewport, changing scale and so on.
    Other changes thats not about the camera position, like style, geometry changes, will update. You have just broken the link to the camera settings of the scene, until you hit reset in Layout for the camera settings for the viewport . Dont hit “reset”, and undo if you hit reset. You now have a completely predictable scale and scope for the viewport.

hmmm are you using sketchup 22 ?

There was something like it last year, couldn’t tell you if it was late 22 or early 23 version, with viewport moving around the page. it was really anoying to some people when others were not affected. I wonder…

Pretty sure it was fixed in 23.1

Yes, this is all set up correctly.

I’m using 2023 version

Thanks, I’ll have a look at this…

Share the LO file.

7231-005-Layout.layout (9.3 MB)
This is one example

well, please update your profile, it says 22 :slight_smile:
23.0 or 23.1 ? the one with the old or new icons ?

If I’m correct and the viewport shifting was fixed mid year, it could change things.

but I might also be incorrect :sweat_smile:

I took a look, opened the SKP file, saved it, checked the LO file again - I’m not seeing that behavior on my end.

2 questions (sorry to be thick)…

  1. How do I update to 23.1?
  2. How do I update my profile

For your profile click the orange initial ‘S’ that marks your posts. Go into the preferences. I think @ateliernab will post a link to thorough instructions.

1 Like

well, there is a “check for update” menu, on PC it’s in… the help menu maybe ?

Or simply download the latest here

follow the tutorial :slight_smile:

After installing, check if the viewports still move around.

this was fixed in 23.1