Viewport content moves about

some advice please:
I do some changes to a scene in Sketchup ie. to change the tags visible in that scene. I probably zoomed or panned some when doing that, and then I update the scene to save those changes.

In Layout the scene has then reflected my zooming and panning, and suddenly my floorplans position on the page needs to be adjusted to show my original content.

How can this be a useful feature? I get that in a 3d view you might want to adjust your perspective in a sketchup scene, and have that reflected in Layout, but for a plan view in Layout, when I have “ortho” set, and a plan view, and a set scale, why would anyone want to update their scope of the drawing in sketchup, and then have that update change what you see in your viewport in Layout? It seems to me that this is a result of viewports being originally meant mostly for 3D content, while, if you use Layout mostly for documentation drawings, this is a “not wanted” behavior. Could Layout just ignore zooming and panning of the Sketchup scene when updating 2D scenes?

I guess I could just “Lock” the scene, or put it on a locked layer, but then I cannot update it to show my intended changes… :slight_smile:

If I wanted my viewport to show just a portion of my plan view, I would adjust my viewport borders accordingly, in Layout, and expect that viewport to always show the same content until I change the viewport borders or zoom.

I guess I could have all 2d content on locked layers, and just go to a page with 3d content, and update the model from that viewport. But that does not seem like a well crafted workflow.

This certainly can be a useful feature. In cases where you don’t want that sort of thing, though, you could choose to update only the scene properties that are to change. So in your example it sounds like you want to update the visible tags but not the camera position. When you update the scene, then, untick the box for Camera Location in the Properties to update panel.

Screenshot - 7_6_2020 , 11_22_42 AM

Or you could avoid moving the camera and make only the changes you need to make to tag visibility and update.

yes. I could have the scene in Sketchup not saving my camera location, but then I don’t have my plan view set at all, and if I visit a 3D scene, that scene´s perspective will show up when I revisit my plan scene in sketchup.

But you are right. In Layout, if the right scene is set, and a camera standard view is set, then my content will not move about when I update the scene, but stay in place. I also found that in preferences, unticking “enable Sketchup model editing” will stop the unintended sudden effects of rescaling ones viewport if one double-click the viewport by mistake. Those two settings combined makes locking the viewport unnecessary, and then I can still access my update button for a selected viewport. That works well as long as your buildings are boxes so you can set the facade equal to a standard view. Luckily I mostly make boxes :slight_smile:

I think you misunderstood me. If you already have the plan view scene set up in SketchUp and then decide to change properties such as visible tags or maybe styles or shadows, you can update those properties without changing the current Camera Position property by unticking the box in the Properties to Update panel.
Screenshot - 7_6_2020 , 11_53_26 AM

Of course if you have Camera Position unticked in Properties to Save then the camera position won’t be saved when you create the scene. Properties to Save and Properties to Update are two different things.

Yes, you could set the standard view for the Viewport in LayOut if you wish although that could create other problems down the road. My preference is to avoid making anymore changes to the scene settings in LO than I have to.

Ah. - of course. Thanks. They are two different things, so there’s the solution.

If I always remember to untick camera location upon update, if I have fiddled with zooming, then that will not be a problem.

I still think though, that Layout should make it easier for me to not disrupt my carefully crafted viewports.:slight_smile: For instance that you could update model instances without selecting a specific viewport, as they are maybe locked, or that you could access the update button for a selected locked viewport. After all, locking a viewport is not so that it cannot be updated, but so it cannot move about.

Anyhow I cannot understand when zooming or panning ones facades and plan views in Sketchup so it changes what content Layout shows is useful ?

You can do that now. Go to File>Document Setup>References, select the .skp file and choose Update.

I don’t find locking viewports all that important. I just lock the layer.

It seems surprising to me that you don’t see it. Suppose you wanted to change the position of the camera for the scene. You are basically indicating that you want to give up the option to do that. So then what? You would be forced to create a new scene instead.

SketchUp needs to know what properties you intend to save when you create a scene and what you want to change when you update it. There’s no way for SketchUp to know that you didn’t want to update the camera position after you have orbited or zoomed the camera unless you tell it.

I get the impression that you will be very excited when they add the mind reading feature although I imagine you won’t like the color of the helmet you have to wear when you use that feature. :crazy_face:

yes. obviously for a 3D viewport, its important to be able to update the camera. For a 2D view, one will change ones scale, and set viewport boundaries around the content in Layout. One does not zoom and pan a flat view in Sketchup in order to change what Layout shows. Not having the viewport change afterwards by accident is important to me, and with as few steps to it as possible. I agree that always unticking update camera upon scene update will fix it though.

You might not. I do fairly frequently.

ok. I think I have found my way through this. The half good solution, to always make sure I don’t do anything stupid and rearranges the zoom and pan position in sketchup before I update a scene does not work for me, It seems I will do those mistakes, and they cannot be undone, there’s no ctrl Z for that. However If I always have my orthographical scenes saved after “zoom extent”, then that seems to be a positioning of the model that I can always come back to. So if I forget to hit zoom extent on a page update, or forget to exclude camera position from properties to update, then I can always redo it, before I update Layout, and also If I found that that my Layout viewport got messed up, I can zoom extent in skechup , update the scene again, and my Layout scene is back the way it was. That seems to work even if I resize my sketchup window, and establishes a fixed placement of the model into the viewport. My own “best practices” will then be to always have othografical scenes set to zoom extent before I export, and have my sketchup template with readymade scenes have that property.

As long as it works for you that’s fine. Since I naturally gravitate toward the easy solutions, I just do as I told you a few days ago and untick the Camera Location in Properties to update before I update the scene. And since the same process also works for changes to other properties like active section planes, shadow settings, and hidden objects, it’s a sort of one-stop-shop.

Best.