Updating SketchUp model in LayOut

SketchUp/Layout 21.0.392, Mac OS BigSur 11.2.1
I created a scene in SketchUp called “Front section” depicting a section cut to show anchor and reinforcement detail inside a couple masonry supports. I inserted the model into Layout and copied, resized and scaled the scene in four places to show top & bottom section details of both column supports. All well and good.

I needed to add more detail to the scene and also decided I should really have separate scenes for the two support columns so I deleted the single scene and created two new scenes in SketchUp called “Column South” and “Column North”. To use those scenes in Layout, I first deleted the existing viewport scene and then inserted the model and selected the two new scenes. I scaled and resized the scenes to show the desired part of the detail. All well and good.

Then I had to edit some scene details in SketchUp so I did that, updated the scenes and saved. I then updated the SketchUp model reference in Layout via the Document Setup. That all seems to work fine.

My questions are:

  1. In the screen shot below when should I use the update icon (red square)?
  2. If I do select one of the viewports and hit that icon, the two viewports on the left are unaffected, but the two on the right morph into something like they have artifacts off the face of the sheet and my scaled and resized viewports disappear. What did I do wrong?

I think you will find that the text arrows still point to the right thing but it is just that the altering of the SU scene changes it in LO and you can no longer see the thing referenced.

Unless you deliberately want to keep LO showing an old scene, you normally update the scenes every time they are altered. That keeps SU and LO in sync.

Simon,
I don’t quite follow what you are saying. No, I don’t want LO showing an old scene. I thought I had deleted all four viewports for the original single scene but apparently not. This is how it looks (and how it should look) with the two top parts of the support columns (“column south” scene is viewport on right and “column north” is viewport on left). As long as I don’t touch the update icon in LO I get what I want by updating SU changes via Document Setup in LO. I’m just trying to determine when and when not to use the LO update icon. And why do the viewports for “column north” go AWOL when I do use the update icon but the viewports for “column south” do not?

If you’ve moved the camera for the viewport in LayOut, i.e. double clicked on the viewport and then panned. orbited, or zoomed, and then added your labels. Hitting Reset for the viewport will reset the camera position back to the original one used for the scene and might, as in your case, make the model appear to shift. If you were to first make sure that Preserve Scale on Resize is selected for that viewport, then drag the top right corner of the viewport out, you should see what Simon indicated. The leaders will still be attached to the model.

Best practice to avoid problems like this is to avoid moving the camera in LO. You can drag the edges of the viewport around to crop the view as needed without any problems. Basically don’t do anything that makes the Camera section of the SketchUp Model panel show as dark gray.

Note also that the Reset button affects the other sections of the SketchUp Model panel such as Styles and visible tags. If you need to reset things in the viewport you may want to consider resetting only those sections that need it.

Dave,
I don’t recall doing any double clicking on any of the viewports, either before or after switching the SU scenes but I suppose it’s possible and I just forgot, although on the other hand, if I did double click on one of the viewports I would have quickly seen that it didn’t do anything I wanted so would have no reason to do it to another viewport. But, only the viewports on the right side have the artifact issue.

I tried zooming out in LO and using Select All to pick up any entities that may be hidden out where the leader lines are pointing but nothing shows up. Should I call Ghost Busters?

Where exactly is the “reset”? Is that the icon I’m calling “update”? I wish the icons showed labels when you hover over them.

I learned about the “Preserve Scale on Resize” in my previous experience with viewports so I made sure that option was selected when I moved from 4 viewports on a single scene to 2 viewports each on 2 scenes.

I don’t remember seeing any dark grey in the camera section when sizing the viewports (but I did see a lot of “red”).

So I guess my underlying issue is still open. Something is obviously awry with the two viewports on the right. Is there something I can do to correct whatever issue I created (i.e. rogue lines shown in my original screen shot) or should I just call it good and not use reset (update)?

Sorry to be unclear. The Update button is not the Reset. Update updates the model reference. If the viewport doesn’t refer to a scene or you modified that scene in SketchUp or, as I saw in a SketchUp file the other day, you aren’t saving camera position with your scenes in SU, updating the reference could do the same thing as resetting after moving the camera in LO.

1 Like

Dave,
Yeah I thought it was the “update” button and I recall using it in a previous project to update just the selected viewport, but it ain’t workin that way now, at least not the two viewports on the right.

I learned from you before that best practice is to create SU scenes to go with LO viewports so that is now my process. Lesson learned. And yes, when I create a scene I save it with all the default options checked.

Since my last posting I’ve corrected all the viewport labels and leader lines so they point to the right items but I still wonder if there is a “gotcha” waiting to pounce with the right side viewports and the update button. Right now I’m thinking, “just don’t touch the update button”.

There’s no need to touch that button unless you make edits to the SketchUp model that need to show in the document. Hopefully you have it all sorted, though, and it won’t be a problem again.

FWIW, that file I was referring to was set up so there wasn’t a single property saved with the scenes. Made the scenes pretty useless and when the references was updated in LO the file basically blew up. On a positive note there were lots of scenes. :roll_eyes:

1 Like

Dave,
Fingers crossed. I’m sure there will be a few updates to the SU model when I get input from a structural engineer before submitting to the building permit authority but it looks like SU and LO are playing nicely together via the Document Setup update.

I didn’t really get my question answered about the rogue leader lines but your re-assurance that a lightening bolt is not imminently about to strike my best laid plans so I’ll press on. Thanks

1 Like

Oh $%#&*. I just did another update to the SU model on a different scene. I used LO Document Setup to capture that change and thought I’d just check the viewports for the column scenes. Well, the rogue leader lines are back, pointing to some non-existent viewports in the upper right of the screen. Okay, I’m gonna trash those viewports and re-build.

Some days the dragon wins.

It would be interesting to see that LO file with the screwed up viewports.

Dave,
Unfortunately, I already started rebuilding the LO file. I tried going back through the undos to get back to the hosed up mess so I could post the file but there were too many steps. Hopefully, things will work this time…but if it is still messed up, you will be the first to know, well, right after me.

1 Like

My “purge and refill” was apparently successful. The LO viewports are all working as they should with no leader lines dashing off to an alternate universe. Mission accomplished, Roger over and out.

1 Like