Side-shifted my viewport yet again

It´s been a while. A month at least. I’ve learned to carefully pay the utmost attention to how I update my scenes. No free loose attention to the actual modeling. Today it slipped. I updated a scene that was panned differently that before. Layout viewport got messed up, all the geometry moved off the page, and all my dimensioning, texting with area references are messed up beyond repair. No undo for this. Just gotta do the whole thing over again. A few hours down the drain, similar to the yearly cost of sketchup.

Oh well. Keep on smiling.

How about going to Preferences>General to disabled SketchUp Model Editing so you can’t double click into the viewport to pan, orbit, or zoom? That would eliminate this sort of problem in LO. Of course if you pan the camera in SketchUp and update the scene, you could induce the problem again but that seems much less likely to happen. If you did that by mistake you could get out of it by reverting to the saved version before you update the scene.

If you aren’t doing it already, keep the SketchUp Model panel open and pay attention to the Camera section when viewports are selected. Don’t do anything that will result in the dark gray background or Reset button for that section of the panel.

I just pan a bit about when I work with my scenes, and sometimes I update the scenes without remembering that I will now store a new camera location to my scene. After that update there’s no way back… I know the different right ways to do it, update the scene and leave out camera location, or maybe not store a camera location for your scene at all. But I guess reverting to the last saved state can fix it. Will try to copy my model content, then revert, delete all, then paste back in :slight_smile:

1 Like

That could be a good option. What sorts of things are you wanting to update about the scene when you do this?

There’s a recipe for disaster!

I think the best option is to stay aware of all the scene properties. It can seem like a lot of balls to keep in the air but you can do it. Best wishes.

@Odd_Haakon_Byberg just wondering something. I use a scene that is strictly for modeling work. This scene is never used in Layout. I then build all the others scenes that do link to Layout and once set, I never change any of the settings or have to update the scene. If I need to work on the model I do that work in the working model scene.

This also helps with setting up templates as well. If you have the same scene in every project, why not have it set up in template?

Has completely eliminated the issue your having in my workflow as linked scenes in Layout never change.


I agree having static presentation scenes will fix it. I like to work directly onto what I will later present, so this method, while I know it works, I want to avoid it I can :slight_smile: I mostly do updates to the tags, with sometimes having tags that are unique to this one model. So what I usually do is, after making other changes, I then click on my scenes to go their saved state, and do my tag changes, and update scene after that. Works fine as long as I dont forget that workflow sequence thing.

You might consider changing tag visibility in LayOut instead of doing it in the scene in SketchUp. At least in my work, I’ve found I can manage with a whole lot fewer scenes in the SketchUp model because I can control tag visibility by viewport in LayOut.

1 Like

yeah. I kind of do a combo, where the most important scenes are in sketchup, and I make additional viewports where I control tags in Layout.
Anyway, I copied my geometry into a different file, closed without saving, reopened, deleted everything, copied back in, went to layout to undo until before the shifting occurred, then reconnected the model and then the dimensions. that worked for the most part, so my crisis went away…

Here’s a quick example. All of this comes from just one scene in the SketchUp model.

nice work. For my part, I need to control some tags in sketchup also, like seeing different plan levels in different scenes.

You can still do that but very probably you can use a single scene for viewports that show plan views of the roof, walls, foundation, HVAC, plumbing, and electrical if you wanted to. Fewer scenes to manage and possibly screw up.

having just one scene used in layout would be nice, but how then to control which sections are active. I guess you need a specific saved scene to control that.

At this point controlling active section cuts does require separate scenes. I hope one day we’ll be able to control them in LayOut, too.

oh my…me too!!!

I do similar to @KeithBrooks , my first scene is my WORKING scene and not used in layout… generally works well

Keith is correct. Any scene that you are exporting to or inserting in Layout should never be edited or modified other than style, shadows, fog. Have a working model scene saved with a quick style, no shadows or fog, profile edges off. This scene is used for editing only and should be your first scene in the stack.

1 Like