Scenes jumping within the viewport

I have scenes set up in SketchUp that all line up, so if you change any scene the model stays in the same location on screen (See first video). However, when I insert the model into Layout and resize the viewport, without double clicking and panning, the scene jumps (See second video). Am I missing something or is this simply a bug? Thanks.

Maybe you could share the LO file? I can’t duplicate that on my end.

Scene Jumping.layout (483.9 KB)
Thanks for taking a look.

It looks to me like the problem stems from your WIP-1 scene having Camera Location disabled in Properties to Save. Once I enabled that and updated the scene to reflect the same camera location as the Scenes P, P25, P50, etc. The viewport behaved as expected when switching between scenes.

I understand the application of scenes that don’t have Camera Position saved. It can make some modeling practice easier. I would recommend not using those scenes in your LayOut document. Or at least fix/save the camera position for the scene before you go to LayOut.

I have done as you suggested, but unfortunately I was still getting the same problem. So, I did a few more test with new Layout and Sketchup files and the problem seems to be with my SketchUp template. I can’t explain exactly why, and I have checked all settings more thoroughly, but I have concluded that I will recreate my template. Thank you again.

1 Like

I wonder what is is about your template. The problem went away for me immediately after saving the Camera Position property for the WIP-1 scene so it matched those others.

Well, good luck with it.