Model in Viewports Jumping

Hi All,

I’m experiencing this strange and serious issue with LayOut. I have a file that, when I update the model, or even re-link it the SketchUp model with the exact same model being used in the viewport, it makes everything Jump to a different location, which as you can imagine, screws up all of my notes and dimensions and clipping masks. This has happened with multiple LayOut files, and each time, what can be seen in the viewport is the same area of the model, meaning, it seems to keep jumping back to the same spot.

I have no idea what this could be. I’ve troubleshooted all of the axis to make sure nothing in the model was moved (even though I debunked this by opening the skp model from the viewport, saving it on my desktop and re-linking that exact file to the viewport, still same issue…).

See video below.
Drawing Reference Viewport Jumping

There is an issue with LO2023 that causes this. The developers are aware of it and working on a fix. Hopefully we’ll see that fix soon.

Is it that if something is made in 2023, and then opening with 2022? Or can you open it with 2023 and it not do that?

If you are using the 2020 version, you should not experience the issue that is affecting the 2023 version. If your profile is correct please upload the model so someone can figure out the root cause.

Hi Dave,

Have you heard if there has been any update on this?

Ive had issues with this alot recently and today I spent three times longer on a project having to constantly reset all dimension lines and annotations.

Ill try 2022 tomorrow as I think this worked fine…

Cheers

Wolf

Exactly what I came looking for - This has been happening to me in the current version, but did not ever happen before when I set my scenese up beforehand in SketchUp.

I just created a sheet with 9 options for a front entry of a building (all in same model on different tags). Labeled each of the views. Noticed I missed painting 1 piece of trim (was a glaring error) and reloaded the model. All viewports shrank back to original screen aspect. I had zoomed in on the first one and locked the scale before making copies. Had to move all the labels.

Best practice is to not double click into viewports to zoom or otherwise modify the camera properties.

Well if mine isn’t a delayed response…

I haven’t set zoom and angle in a SketchUp viewport in years. I’m specifically talking about perspective views that are set by scenes. I will expand the viewport to get the portion of perspective I want to fill a certain amount of paper size, lock the scale, then bring the corners back in to crop the perspective.

When I reload the model (and sometimes when I just reopen the file) the model reverts back to full perspective but shrunk to my smaller corners, ignoring the scale lock. It even happens when the layer I use is locked.

i’m having the same issue with the 2024 version…
still no salvation?

Share your LayOut file so we can see what you are working with.

Please correct your forum profile. It says you are using SketchUp Free (web) 2020.

ישרוטל ים המלח - חדר לדוגמא.layout (7.3 MB)

You’ve modified the camera position in some of the viewports from what was set up in the scene in the model. If something happens to reset the camera properties for the viewport, the model will appear to move within the viewport and relative to other content on the page. For example this one on the last page


After resetting the camera. Compared the edges in the model viewport with the top of the rectangle.

There’s no need to modify the Camera position in the viewports.

I see
i had no intention to…
so correct me if i’m wrong, if i select a view and the reset button under camera options doesnt show then the viewport should remain unchanged when i update the model reference and render?

If the camera position property is saved with the scene and you do not change the camera position and update the scene and you do not move the model within the model space, the model should not move within the viewport when you update the model reference in LayOut.

ok, thanks a lot Dave

1 Like