Very frequent crash (not a bug splat) Pro 21

I am experiencing this crash in SU 21 for the first time on a new system running Windows 11.

The new laptop is an HP Omen 16-c0006na Ryzen 7, RX 6600M.

I would appreciate any help or insight into where I might be going wrong.

Thank you all.

When does the crash occur?

Was SketchUp installed correctly by right clicking on the downloaded installer and selecting Run as administrator?

Have you updated the graphics drivers directly from the GPU manufacturer?

Start by upgrading everything you can

  • get the latest graphics driver from AMD
  • check that you are running the latest maintenance version of SketchUp
  • note that SketchUp 2021 is not officially supported on Windows 11
  • if you are using extensions, try disabling them. If crashing stops, try identifying the culprit by re-enabling them one by one.
1 Like

Yes, installed as administrator.

Now updating the graphics drivers.

Thank you for your quick reply.

The crash was occurring most when using the orbit tool.

Updating the graphics drivers seems to have worked though, so thank you for that simple advice.

All the best,
Nathan

1 Like

Hi Anssi

Thank you for your quick reply.

Updating the graphics drivers seems to have fixed the problem.

Thank you very much indeed,
Nathan

Good deal. One of the things I dislike most about moving into a new computer is you have to update pretty much all of the software on it because it’s old by the time you get to unpacking the computer from the box.

It didn’t even cross my mind. Will always remember this simple procedure from now on though.

Thanks again.

1 Like

Hi I’ve got the same problem I’ve got HP Omen 16-C0322NW with Windows 11 and GPU GX 6600M.
I updated everything on my computer, (windows, GPU software etc.)
unfortunately often on my screen appear crash with lot of spots on screen and BUGSPLAT dialog box
Do you have any ideas what’s wrong?

Typically the sort of thing you describe is traced to bad graphics drivers. Go to the Radeon site and get their latest drivers to install. After installing them, make sure SketchUp is installed correctly by right clicking on the downloaded installer, choosing Run as administrator and then Repair. After all that do a power off reboot of the computer and see if things work better.

ok TY i will try to do that

still the same, lot’s spots on screen and “no answer”, have u any ideas?

Look in SketchUp’s Preferences>OpenGL and see what graphics card it is using.

Are you running your computer on battery?

I always work with charger,
graphics is ok
image

update: the problem is like on video.
problem is only when I have GPU RX6600M switch on. when only Radeon graphics is on in device menager problem doesn’t exist.


any ideas?