Upon loading of sketchup 2024, error: failed to load/read localize.rbe

error appears:

Extension Errors Report
SketchUp: 24.0.553
OS: Windows 10  Ruby: 3.2.2

Extension: [unknown]
Error: Failed to load file (Failed to read RBE/RBS file.)
C:/Users/user/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/habitat_site_context.rb:6:in `<module:HabitatSiteContext>'
C:/Users/userAppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/habitat_site_context.rb:4:in `<top (required)>'

indeed in that script, on line 6 this appears:

Sketchup.require(“habitat_site_context/localise”)

the habitat_site_context subdirectory is there, but, no “localize” anywhere in that area…

the program allows to “uninstall” however, that does not fix anything , error appears on next startup… the only “fix” is to rename that file at the OS level, then no error is reported… just wondering if this is a known issue, where is that localize file expected to appear/come from?

Do you have a plugin called like that? When you say “uninstall” what did you uninstall?

This is the Add Location extension. SketchUp 2024 is distributed with this extension. (The "localise.rbe" file should be there in the extension subfolder.)

FYI: You should not copy an old version from an old SketchUp “Plugins” folder.

I suggest to repair the SketchUp installation.

Navigate to "%AppData%/SketchUp/SketchUp 2024/Plugins" and remove any extension files you may have copied from SU 2023 (or older.) Delete all files and subfolders in that “Plugins” directory.

Then, if you have run SketchUp this session reboot your computer to clear out memory.
After the reboot, locate the SketchUp 2024 installer exe, right-click it, and choose “Run as administrator”. Within the installer panel, take the Repair option.


And yes, “localise” is spelled wrong for English, but this doesn’t matter to Ruby.

right, mis-spelled localize.rbe… it is in fact there: localise.rbe (1,222 bytes) May 8th, 2024…

The install, as well as repair As-admin was already done at the start, and even now, tried to rename the top level Sketchup under Roaming… it re-created everything, and still, complains that file cannot be opened at startup…

ScreenHunter_115 Jun. 18 17.22

I did not reboot yet, since installation, so, maybe that will help, otherwise file is there under right directory, and user has full privs to read, also opening in notepad works (even though it’s binary), not sure why the program fails… if any other ideas be glad to know, otherwise will post once reboot is done. thanks.

Do you have any Unicode characters in the machine’s %USERNAME% ?

And can you confirm you are running SketchUp in English?

Also … SU2024 comes with Add Location v 1.5.5, but there is a newer version in the Extension Warehouse which is v 1.5.9. Have you tried to update it and restart SketchUp ?

there was another (builtin) extension that gave same error, didn’t think much of it, and clicked uninstall, it did not return, this one does not respond to uninstall :slight_smile: :slight_smile:

Extension warehouse opens a browser tab, login works, says you’re all set, but going back to the main window, shows blank white page… closing and retrying, same thing, so the “handshake” for the login does not really work, i don’t have any firewall…

disabled anti-virus, no luck, so, not sure how to update that plugin…no unicode or anything special, username is all lowercase english.

oh, wait, warehouse does eventually load, takes it few minutes (6-10minutes) of white-screen, then shows up, but any search/operation takes few minutes (again, 5+ minutes) to find/search, not sure , never really used it… :slight_smile: maybe reboot will help, will update thread.

I think the extension warehouse may be having issues right now - it’s not loading for me either.

ok, thanks, reboot did not clear the issue, still upon initial startup it fails to load the localise.rbe, claiming to not able to read file :slight_smile: nothing in windows even viewer… the file is readable using the same user from file explorer…

You may want to check SketchUp’s permissions

I just opened EW from within SU24 without problems. Then installed CleanUp3 without issue.

ok, some progress, so, reboot did not resolve. it appears to not be related to localised , but all extensions, looking in manage extensions, see “Dybnamic components 1.8.3”, and “sandbox tools (2.3.5)”, both disabled, and earlier showed similar issue, fail to read upon startup :slight_smile:
So disabling removes the pop up at startup (and disables the extension)… the add location, is not possible to disable to uninstall, it keeps coming…

about this:

how would you go about doing that?

warehouse opened , and managed to install the updated add location, it said successfully installed, does not show version in extension manager…

here is a screenshot… the error now appears on all 3 extensions, something in the user profile or folder is not to Sketchup’s liking, not sure what’s going on, all other programs are running fine, no issues with permissions, or anything, tried to uninstall and reinstall several times, seems like something with permissions, but not sure how to brute-force open it all up, since this is a single user environment, no worries from other users…

The fact you can’t see the version is a bit suspicious.

Easiest way - uninstall it. Re-install it : Right click the installer and run as administrator when you do.

If this doesn’t improve the situation, You could also try making a new user account on your machine and seeing if it works correctly there

1 Like

Thanks, the initial install was run-as-admin, subsequent repair, also, where, run as-admin… did it just now as sport, to be 100% certain, move roaming folder to side, run-as-admin installed successfully, still errors on all extensions…

uninstalling the reinstalling the extension, still does not show version, however the error appears on the other two extensions as well , that DO show full version number…

this is the welcome pop up screen with all 3 enabled :slight_smile:

new user, that would be an overkill… later will try to completely unstinall, it’s possible this PC had a very old version of sketchup… maybe something was left order and interferes…

I read that running Sketch up itself is not recommended as admin, should i try that or will that destroy more things ?

No, it is a test. Sometimes user profiles get corrupted.