Failed to read RBE/RBS file

Hi to all.
I’m a newcomer in the Community :slight_smile:

I just want to explain a problem loading plugins:

When Sketchup PRO 2017 starts (with regular license), it does not load the preinstalled plugins and displays the “Failed to read RBE / RBS file” message for each plugin.
If I try to install additional plugins from the extensions warehouse, the error message shown above is displayed at startup.

I claim that I use it on a PC with windows 10 professional and with the Sketchup system folders delocalized on the corporate server. The peculiarity is that if I install sketchup locally on my pc everything works regularly. If I install sketchup by setting up the installation folders on the server, the problem appears.
I do not think the place where Sketchup system folders are located is the cause of the malfunction as we have purchased additional paid plugins (based on .dll and not ruby ​​.rbe - rbz scripts) that work perfectly even with sketchup system folders installed on servers. The plugins in question are simlab PDF3d importers and STEP importers.

We could not solve the problem. Any help?

I think that you have answered your own question. If some plugins work and others don’t, it is clearly a problem related to the way those particular plugins are written. Probably they have some hardcoded file names and paths. I seem to remember some plugins having problems with non-English language operating systems too.

Thanks for the reply.

I use SK PRO 2017 in english language but windows in italian language.
Plugins that do not work are those pre-installed by sketchup at the time of installation:

  • Advanced camere tools
  • Sandbox tools
  • Dynamic components
  • Photo textures

I’ve tried to install some other plugin from official extension warehouse but nobody worked (written in ruby).
I’ve tried to install some plugin previously purchased (based on .dll) and work well.

I can understand that additional plug-ins that are not released by trimble may not be fully compatible. But neither pre-installed ones will work.

If I install SK PRo 2017 locally on the pc (drive C:/) everything works, but for business management issues of projects and backups I need to relocate some folders to remote disk. Practice that works fine on all the other software used in the company.

Best regards,

Can you elaborate on how you relocate folders?
Are you relocating the Plugins folder?

I’ve tried both ways. Now the plugin folders is located on the pc.

sk1

The failure of the shipped su_* files to load as SketchUp starts might be indicative of an improper installation.
SketchUp needs to be installed by using ‘Run as administrator’.
Doing it any other way - e.g. by double-clicking on the installer’s icon - even when you are an admin - will NOT create a correct installation.
This can manifest itself in various unpredictable and weird ways - such as missing shortcuts, or some ‘shipped files’ not copying and then loading [probably because SketchUp thinks it has insufficient powers to write files into your user’s Plugins folder etc].

You probably don’t need to uninstall/reinstall… try this…

Close SketchUp.
Find the SketchUp installer exe file - probably in your Downloads folder ? - if not found re-download it.
Select the icon, right-click > context menu and choose "Run as administrator"
When prompted choose "Repair"
When its completed try restarting SketchUp…
Any improvement ?

Although I did not specify it before, SK was installed strictly through “run as administrator”. All the indications found on this network for this issue have been tested.
At this point I think the problem is some kind of bug in sketchup programming. All the other software used in the company on all dozens of workstations work perfectly with system folders on external servers.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.