Unable to Connect. Please check your internet connection

I have just installed 2020 and I can’t launch the program because it has I have no internet connection. The internet connection is fine. I have Windows 10, Latest Google Chrome. IT tells me all firewalls and ports are open. It works on my laptop and the guy next to me is operating just fine. What is this?

from the online SketchUp User Guide

Dan’s articles don’t mention Bing. Does bing.com work in a browser for you? If it doesn’t try to fix that, and then try SketchUp.

Colin, can a user add their own URL for online checking to the
%LocalAppData% ... PrivatePreferences.json file and will it work ?

Ie, the value is empty in the file as distributed, but the key is there, … so it makes me wonder.

{
    "This Computer Only": {
        "Preferences": {
            "OnlineTestURL": "",
        }
    }
}

Yes,

https://help.sketchup.com/en/sketchup/cant-connect-web-tools-3d-warehouse-extension-warehouse-add-location-and-licensing
:slight_smile:

[quote=“DanRathbun, post:4, topic:115732"] and will it work ?
[/quote]
If you’re behind a proxy, it doesn’t.

1 Like

That was only true for a while. It was removed in 2019.3 when bing.com was set to be the URL to test. Unless you have found that adding it works?

The Help Center article is still there even when the version is changed to 2020.

IMO, IT managers should still be given the option to control the online check.

1 Like

This was the fix. It happened to my co-worker sitting next to me as well when he upgraded to 2020.
{
“This Computer Only”: {
“Preferences”: {
“OnlineTestURL”: “”,
}
}
}

1 Like

Hello, I wanted to surface this issue again. An employee next to me is working on a Mac. They are having the same issue. The only problem is that on the Mac side they have to OnlineTestURL line in the .json file to edit. It’s a much smaller file on the Mac OS side. Any ideas on how to resolve this?

{
“This Computer Only”: {
“Application”: {
“CID”: “838bb9d3-6103-d748-9761-d3ad9f23f2fa”,
“RunCounterSU”: 1
},
“Common”: {
“AcceptedEULA”: true
},
“File Locations”: {
“Classifications”: “/Users/jtani/Library/Application Support/SketchUp 2020/SketchUp/Classifications”,
“ComponentBrowser”: “/Library/Application Support/”,
“ComponentBrowser1”: “/Library/Application Support/”,
“ComponentBrowser2”: “/Library/Application Support/”,
“Components”: “/Users/jtani/Library/Application Support/SketchUp 2020/SketchUp/Components”,
“Images”: “/Users/jtani/Documents”,
“ImportExport”: “/Users/jtani/Documents”,
“Materials”: “/Users/jtani/Library/Application Support/SketchUp 2020/SketchUp/Materials”,
“MaterialsBrowser”: “/Library/Application Support/”,
“MaterialsBrowser2”: “/Library/Application Support/”,
“Models”: “/Users/jtani/Documents”,
“Styles”: “/Users/jtani/Library/Application Support/SketchUp 2020/SketchUp/Styles”,
“StylesBrowser”: “/Library/Application Support/”,
“StylesBrowser2”: “/Library/Application Support/”,
“Templates”: “/Users/jtani/Library/Application Support/SketchUp 2020/SketchUp/Templates”,
“Textures”: “/Users/jtani/Documents”
},
“Toolbars”: {
“Trimble Connect.Visible”: 0
}
}
}

Send a message