Sketchup Connection Error

A number of our users are getting connection error messages and cannot open Sketchup.
image

We have internet connectivity and the firewall ports are open. It does not affect all our users. Could this be specific to 2024?

1 Like

i am having the exact same problem!!

Same problem

Same problem here!
We have perfect internet connection but SU can’t make connection to Smart Works, Google Warehouse,…

This issue is that bing.com is down for several countries: Bing down? Current status and problems | Downdetector

SketchUp Desktop uses bing to detect whether you have a working internet connection.

1 Like

Online Test URL has details on how you can change the OnlineTestURL to work around this. @evm-creation @Syksy @Bram_HusInterieur @ngerhardi @Wout @Jacolene

1 Like

Yes thank you. But these to me seem to be only for Windows! Any suggestions on how to do this for MacOS?

I’m on windows and this has not fixed the issue.

I also thought we didn’t need an internet connection to use Sketchup PRO?

Same here, using 2024.

I tried this solution but it doesn’t work

same here, i could not connect sketchup to the internet, and tried everything, version 2024, i was able to update to the last version today but no connection to the internet in the program

On Mac you can choose Go to Folder… from the Go menu in Finder, and paste in this path:

~/Library/Application Support/SketchUp 2024/SketchUp/

Change the year number to get to other versions of SketchUp. In PrivatePreferences.json you would edit the line “OnlineTestURL”: “”,

I tested with “OnlineTestURL”: “https://www.sketchup.com”, and that then let me sign in.

1 Like

I am watching this page to get a sense of how bad the bing outage is:

https://downdetector.com/status/bing/

I have a SharedPreferences.json file on my system and had to ad the line to the windows section for it to kick in.

2024-05-23_11-29-57

It has nothing to do with Bing, I am working from chrome and have the same problem.

It isn’t anything to do with Edge, the browser, but it is to do with bing.com, the web page. Editing the PrivatePreferences.json file to change the URL that is checked will work around the bing.com outage.

That will have worked, but further down in the same file is a Preferences section, and adding the line there would work for Mac and Windows.

its back! at least for me

it’s fixed for me