I can't sign in, please help

When I’m going to sign in, the programme tells me that I’ve problems with the internet connection, but in my computer, everything is fine. What can I do to sign in?. Thank you so much.

SketchUp by default relies on being able to read bing.com in order to tell if you are online. Do you have that blocked? Like, can you get to bing.com in a web browser?

I can see from the screenshot that it was a Windows update and pending a restart. Sometimes it’s causing a bit of trouble. Restart the computer to see if it helps.

1 Like

Yes, I can get to Bing.com in my browser. So, I believe that it’s not the problem. Do you have another idea about what’s happen? Thanks so much for your answer.

I restarted my computer but I continue with the same problem. I don’t understand what’s happening. Thanks for your answer.

The update probably messed something up in the settings of the default browser.
Try changing it to a different one (Standard Apps)
Launch SketchUp and try again.
Usually setting the standard to your preferred browser ( which could be set to remember your logins) will work from then, until the next update of Windows…

1 Like

Some idea

  • You are maybe behind corporate firewall or proxy
  • You can try to to set the default browser in Windows settings

(Edit: @MikeWayzovski was faster :wink: )

I think that it won’t be the default browser, though I would be happy to be wrong about that! The error that is showing appears before SketchUp asks the browser to open.

Could this be because SketchUp site is down? Getting a 503 error from their website currently.

I see that sketchup.com is down at the moment but no problem getting into SketchUp for Web.

Probably a server issue that will be fixed ASAP.

Seems to be a planned outage. Getting a 503 error rather than a 404. Usually that means they intentionally took the site down. Pretty poor planning to take it down in the middle of the morning, but seems to be happening at 8am PT, so I’m guessing the team just got in and didn’t want to work in the evening or weekends.

What is the URL you are using for SketchUp for Web? Might try that instead.

It is “feierabend” here :wink: ,

totally right planning for me! :stuck_out_tongue_winking_eye:

I’m using this link.

They probably didn’t know you were going to work on your hobby right now.

1 Like

Thanks @davebest that link worked for me! Still waiting for the website to come back, but at least I can get started on a new design.

I started to use little snitch, to prevent all kinds of apps to infringe my privacy by calling home about what I am doing.
Then Sketchup starts to crash because it connects to Bing. I cannot think of any reason why sketchup should give my sketchupuse to microsoft.

SketchUp tests that you are connected to the Internet by checking the existence of bing. Otherwise it doesn’t use it in any way nor convey anything there. There was a recent thread about replacing bing with a site of your choice by editing the plist files or the registry.

If you want to change how SketchUp decides if you are online, you can follow this article:


Look for the part that begins with “Alternatively, if you would like to change the URL that SketchUp uses to test connectivity…”

Tx Colin for the clearance. I’ll change the check to my liking.
What happened was also: from the moment I blocked bing (connection) skp crashed on startup. Had to Re-install (including plist removal), all running again.