Couldn't sign in to the SketchUp application

Hi! Does anyone encounter the sign in issue?
When I launch my SketchUp application and click the “Sign In” it will lead me to browser.
After I signed in my Trimble ID, I received the “You’re signed in to all things Sketchup”

But once I go back to my SketchUp application it will repeat the sign in process " Launch Browser Again"

I tried it to different computer but still having the same issue. Please help. Thank you!

I haven’t seen that combination of issues. Is there anything unusual about the security settings in your system?

Nothing unusual.

I even tried it to different computer but still facing the same loop.
I already got the confirmation signed in, but after I close the browser and go to my application, nothing changes. It will ask me to sign in again to browser.

@Bryceosaurus can you think about what would explain this? We’ve had cases where the browser failed to launch, but I don’t remember one where after successfully signing in that SketchUp wasn’t updated.

Here’s what I’m getting . After the confirmation that all things signed in, My SketchUp application still asking me to Launch Browser Again and sign-in.

I’ve tried it to different computer but still facing the same Loop/

Might wanna try changing the default browser temporary in Windows.

Problem solved. I inform our IT guy to whitelist