Trying to get started and can't sign in through the software

When I open the sketchup pro 2021 software it brings up a log in screen. I hit log in. Then it brings up a button that says “launch browser again”. That button does nothing and the software may as well be a $300 brick right now.

When you installed SketchUp did you right click on the downloaded installer and choose Run as administrator? If not find the installer and do that. Then, if presented with the option, choose Repair.

After trying the repair option, if you still see the same problem, check which version of Chrome you are using. Earlier in the year we saw a few cases where Chrome did not open when asked to do the sign in step. The solution is to either update Chrome, or set your default browser to be Edge or Firefox.

Thank you both. I tried everything all the way through reinstalling chrome. Nothing worked. But I set Edge to my default browser and it fixed it for me. Thank you very much.

This topic was automatically closed after 186 days. New replies are no longer allowed.