Typing "0.5" in Layout pt selection boxes causes a lock-in

When editing lines’ or dimensions’ pt widths in the “Shape Style” editor, and typing “0.5 + Enter” into the boxes, the mouse cursor can’t be removed from the box.

It feels like the focus of the keyboard and mouse is kind of locked into the box being edited. Pressing space bar or using escape doesn’t work, or any other shortcut keys. Anything being typed is shown in the locked-in box. In rare cases something gets me out of the box, but what key or clicking combination does this isn’t clear. Sometimes when another number is entered (for e.g. 1) it gets me out again. Most times I have to close the program with the top right cross and click save then reopen to have a normal layout again.

This bug occurs regardless of model/layout file, and is easily reproducible.

Not by me it isn’t.

I’m not seeing this behavior either. I type 0.5 and hit Enter and the selected lines change width. It doesn’t freeze for me at all.

I have not tried in LO 2019 yet, but had the same problem in LO 2018, trick was to keep the stroke thickness as a whole value and change it last to something smaller than 1 (when required).

That’s interesting. I’ve never had any problem with changing line weight values to less than 1 at any time working. I wonder what’s different.

I’ll try to figure out how it happens exactly and come back here with some more information.

Just thought there’d be more like Julian_Smith who know what I mean. Two of my colleagues in the office also have this issue on their Layout 2018 and 2019.

I just tried to reproduce this on Win 10 Pro with LO 2019.2.222. No crash, hang or lockup when changing stroke, start/end arrow values. Entering something smaller than the min supported value will change to the min supported value when tab or enter is pressed. No issues whether an entity is selected or not.

Did this issue exist (for you) with versions prior to 2019.x?

Are you using the same decimal separator as with SketchUp (dot or comma, depends on your regional settings)?

Try to disable Sonos or Spotify or (any) other services running.
I also have experienced weird mouse cursors and input fields being ‘hijacked’, you are not alone.
Textexpand-software or certain mouse settings, etc.
can interfere with supposedly LayOut behavior, but to really know what is happenng, one has to take in account all the other processes as well.

It’s been happening in our office (including me) since 2018.x , possibly 2017.x, but I’m not sure I can remember that far back sorry.

I’ve had a look again, and when opening a “fresh” template, it doesn’t do any kind of lock-in. It seems to be once a drawing has been fleshed out with multiple sheets etc. that it starts happening.

The latest one it was happening in I’ve reduce to 1 sheet and stripped of all information that is under an NDA and attached it.

After doing so it still does a form of the lock-in, where selecting or drawing any line then trying to change line pt to 0.5 and trying to then click the box below it being a problem. Clicking on the sheet solves it though, which doesn’t always happen, often it wouldn’t allow clicking anywhere besides the close button.

For some reason the file is ~32Mb, and has been stripped of all referenced files, so I’m not sure what that’s about either.

Hopefully with the attachment someone else can reproduce the bug?

Edit:

Link to LayOut file: https://drive.google.com/open?id=1svsb1aVTJ_t0BcJmQWtdYtMoHq3E3vYZ

Did you purge the unused in Document Setup/References? Is there a SketchUp file included? Has it been purged of unused stuff?

Maybe best to leave it alone. If you purge that stuff, it might fix the issue and we wouldn’t see it. Upload it to Drop Box and provide the link.

I did purge the references and nothing is included in the references list anymore.

Saved, re-opened, and it still has the bug, so I’ve given the link for that one.

OK. I’ll take a look.

Well, I drew a line, changed its weight to 0.5 and changed the scale. No problems, no locking up.

It’s definitely still happening here.

What happens if you hit Enter after typing 0.5? What happens if you omit typing the leading 0? It shouldn’t matter but…

Just to avoid doubt, did you install SketchUp correctly? That is, did you right click on the installer file and select Run as administrator?

Try this: quit out of SketchUp and LayOut, find the installer (if you don’t still have it for SU2018, you can get it at sketchup.com/download/all ), right click on it, choose Run as administrator, and select the Repair option. After it has completed. Shut the computer down completely and restart (cold reboot). Any change in behavior?

I’ve always been using Enter after typing 0.5, I tried omitting the 0, and I also did a repair installation (As Administrator) and restarted, with the same buggy result.

I’m not sure what else it could be on the PC perhaps, but none of the software mentioned above has been installed. My colleagues also have different PC set ups.

Could you download and install SU2019.2 and run the trial? See if you get different results.

I currently have SU2019.2 installed, I don’t think that would be possible then right?