Can't input values with keyboard

Am I the only one driven crazy by this buggy, unstable program? I hate being captive to it because there’s no competition.

Today, I had to remove it and re-install it because for no apparent reason the keyboard shortcuts suddenly decided they weren’t going to work any more. They didn’t work after the re-install either, until I went in to view/preferences and began assigning them manually, one by one. Then, all of a sudden, all of the pre-sets began working again, including the ones I hadn’t gotten around to re-assigning. Hooray! All is copasetic again.

For about 5 minutes. Then, the measurement box in the lower right hand corner decided it would no longer accept inputs from the keyboard. If I draw a guideline to establish a distance, I’m stuck with whatever approximate value I get with the mouse. Same with the bulge for an arc, the diameter of a circle, etc. My keyboard is working perfectly well with any other program. There’s no help in any of the help sections or the FAQ of this forum. Anybody know what the hell is going on?

1 Like

Please describe exactly how you are entering text in the Measurement box.

Now, are you saying that whatever you were doing to enter text before used to work fine and now the thing just suddenly got fussy?

Have you checked to make sure that your NumLock is engaged?

-Gully

I’ve not heard of anything like this before.

Sounds like an issue with your keyboard rather than SketchUp.
Perhaps a loose connection ?

As Gully said - exactly how are you entering this.
Clicking the mouse on the Measurement Box will usually break the flow.
Get to the point in the tool that will take input and simply type it + enter.

The fact that your shortcuts are screwy too, does suggest an issue with the keyboard…
NumLock, loose connection etc ?
What kind of keyboard is it PS2 or USB, wireless etc ?

Windows also has a #*@%& “helper” feature called Sticky Keys that can be activated with a key combination that I have forgotten but that I have a couple of times used accidentally. It is meant for people who cannot click two keys at the same time, and makes the typing of anything difficult for those who can, and almost makes you crazy until you find a way to turn it off. Also, alt+shift will change your keyboard language on the fly (also easy to hit accidentally). Windows NT had a keyboard shortcut that turned your display image upside down (mostly used as a prank on coworkers).

I have also met stuck Alt or CTRL keys.

Just ideas

Anssi

2 Likes

Well, well, well… I just wouldn’t have expected it from you @Anssi, that is Very Funny indeed — I Love It !!!

I’ve entered measurements for years successfully using the following format for feet and inches: e.g. 6’ 7". For a multi-dimensional shape like a rectangle, I separate those values by a comma: 6’ 7", 3’ 4". My problem, I’m sure, is not an incorrect entry. In the past, an incorrect entry simply didn’t produce the desired result. Now, nothing I type registers; the original value remains in the measurement box. I’ve tried clicking on the box, and erasing the original entry, nothing enables me to produce an input.

I know what Anssi is talking about with sticky keys and other accidental inputs changing keyboard logic–and feel the same !?% way about it; but I have no idea what I might have done in this case, or how it might be undone if that’s the problem.

Thanks to all who have taken the time to respond to my problem. Hope this gives you an idea about what’s going on. I use a full-size USB 2 keyboard with a number pad. Num Lock is off, as it always has been in the past; I’m not experiencing the slightest problems otherwise with my keyboard. My shortcuts are again functioning normally, and although I know correlation is not causation, that problem disappeared while I was inputting to View/shortcuts, which to my mind suggests a balky program rather than a balky keyboard.

If you’re trying to input numerical values using the numeric keypad and NumLock is off, it will behave the way you describe; that is, nothing will happen. To rephrase: in order to type numbers using the numeric keypad, NumLock must be on or you will be entering navigation commands such as PageUp, Home, and left, for instance. Just look at the captions on the keys.

Notwithstanding your recollections, NumLock does exactly what its name says: when it is engaged, it locks in the numeric register of the keypad; when it is not engaged, it issues non-printing commands.

-Gully

Gully (and Tig) you are absolutely right. And apparently my recollection is absolutely wrong. I found that I was able to input values using the number row across the top of the keyboard; I then tried NumLock On using the keypad, and of course it worked. I think I thought NumLock was off because of course it was always on and I wasn’t paying any attention to it. But of course the keypad doesn’t input numbers unless it’s on the numbers setting. I knew that. Duh. Think my confusion came from not being aware that I had accidentally turned it off.

Anyhow, I don’t know what time zone you guys are in, but if it’s east of CDT thanks to all who stayed up so late in the effort to overcome my stupidity.

And I guess I owe SketchUp an apology on this one, although I’ll never forgive it for the years it kept turning back edges back on again every time I turned them off.

I have been teaching SketchUp in a classroom environment and have been encountering the problem with disappearing shortcuts at least once a week. I don’t remember having this problem in other versions than SketchUp 2016. We don’t use a lot of custom shortcuts, so just resetting them all in the preferences windows goes OK for fixing this, but I have began to start exporting them for my own workstation for the rare occasion that it does happen.

I have actually seen some occasion where users have updated their SketchUp version, and the default shortcuts nor the modified shortcuts carry in, therefore the reset fixes the problem. I am not 100% sure if that is the trigger though.

Don’t even worry about it. You’re not the first person this has happened to. I’ve heard many a forehead being slapped over NumLock.

-Gully

All of you people who use Windows as the O/S makes my day in the morning . . I get to Laugh at the problems you have . . I will most likely get yelled at again . . I use Ubuntu 15.10 64 bit and add Virtual Box run windows 7-1 in there it has its own drivers for windows and I never get ANY of the problems you people have . .
If you want more info on how it works you may write me . .

NumLock is a hardware setting that is independent of the OS, although the OS may use software to control it. The guy already admitted to hitting the key accidentally.

The point is, this is like someone having a problem with his mouse and you coming along making an irrelevant crack about Windows. Why don’t you just assume that everyone is smart enough to choose an operating system without your guidance? Actually, your repeated unsolicited testimonials to Ubuntu make it sound like you’re insecure in your own decision.

-Gully

6 Likes

I have a similar problem. Not always but when I point my curser inside the material selector the cursor does not go back to measurement input dialog. Any new keyboard input goes to material selector box.

I have to exit and reopen all sketchup windows to become normal.
Thanks,
Niranjan

Hi @designtreeindia

What you show in your screen shot looks like the ‘Layers’ Drop Down list to me.

If so, that’s an entirely different animal compared to the VCB box, or the materials palette.



IMHO this Layers control box is not working well. And I’d avoid using it for the time being.

Once you click within it, it holds it’s focus, and doesn’t release it. Maybe there a specific exit routine that needs to be done, but from I can tell this looks like a bug.

Now for the bad news… I’m not sure I see what the point of this is anyhow—it seems to me that it actively encourages the bad practice of drawing raw geometry directly onto various layers. Which goes against the preferred method of always drawing directly onto the default ‘Layer 0’ , and then afterwards reassigning the geometry to a different layer.

From what I can tell right now, the layers drop down list does two basic things. . .

  1. it allows to choose what will be the active/current layer.

  2. you can type in a name, and it will create a new layer for you.

IF it had a 3rd use, I’d expect that it would also allow you to toggle on/off the visibility of a layer. But I don’t believe this is possible, from what I can tell. And unfortunately I think that’s the one really useful thing it could do. when compared to the other two.

I think you’re better off using the Layers Window, in place of this drop down list.

but that of course assumes it is the layers drop down list. . . maybe it’s not.

You can easily determine it by hovering your mouse cursor over it and wait for it’s pop up message to appear.

I believe that this is a known issue on MACs.
If the Layer Manager toolbar box is selected it then takes subsequent keyboard input, sometimes unexpectedly.

On a PC this doesn’t happen…

Hi @TIG,

Do you Windows guys have a visibility box built-in to your Layer Manager toolbar?

The PC’s Layers Toolbar is pretty useless IMHO !

There is only the ability of changing the active Layer off a dropdown - which is useless, since Layer0 should be current 99.9% of the time.

The Layers Manager dialog is different, as you can see…

You can use the tick-boxes to control visibility - best never to reset the active Layer with the radio-buttons.
To add a Layer you click the [+] button - to delete a Layer you use the button.
You can also change the Layers’ colors…
You can also ‘sort’ the list order…

On a PC to change a selected object’s Layer you use Entity Info, but you choose off a drop-down list - you can select that box and then type in a Layer name and it’s then selected - but only IF it exists - perversely, on a MAC. typing in a name adds a new Layer if it doesn’t exist !

1 Like

Thanks for the screen shots @TIG

I appreciate you taking the time to do that.

Thanks Again, and Take Care,

Jim

Ops Sorry its the layer drop down!
Niranjan