My.sketchup.com does not accept keyboard input for me

keyboard
measurements
my.sketchup.com

#1

Hello!
I am a new member in this community. This is my first post and I am not a native speaker, so be gentle. :slight_smile:
I have searched the forum but found no entry dealing with my problem in my.sketchup.

I assume I must be missing something. I can not enter precise measurements like in normal sketchup. For example: I have a simple cube with 1m x 1m x 1m. I want to make it 1m x 2m x 1m. Usually I choose the scale tool, grab the center manipulator on the right side, drag it in the right direction, and input “2m” by keyboard.
I have no numerical block, so I use the normal number row above the letter keys…

It does not work, and when I hit the m the “Mark” tool seems selected.

I guess I am missing something obvious to all of you. Would you mind sharing? Life without numerical input seems pointless.

Thank You!


#2

What if you draw the cube at 1m x 1m x 1m from the beginning? Will it accept your inputs then?


#3

Typing 1m in the the scale tool wil set the scale in the red plane at 1m. Since your cube is 1m, nothing would change…
Try to select the scale tool, grab any control handle and type 2m;3m;4m , it should give you a box with these measurements


#4

Works for me. My work flow was:

  1. Select rectangle tool
  2. Click origin
  3. Drag a rectangle
  4. Click to finish
    (units were feet inches)
  5. With keyboard enter “1m,1m” ( numbers above letter keys even though I do have a NumPad)
  6. Hit key (rectangle becomes a 1*1 meter square)
  7. Select “Push/Pull” tool
  8. Click on square
  9. Pull upp (dimensions in box are still feet & inches)
  10. Click to finish
  11. With keyboard enter “1m” (result: a 111 meter cube)
  12. With select too drag a box around the cube to select it all
  13. Hit <“s”> key (to get “Scale” tool)
    14: Click on a side of the cube to show handles
  14. Drag a handle in the center of a face (“Scale about opposite point”) (now the measurement units are a decimal number which happens to be meters because of the 1 meter size)
  15. With keyboard enter “2m” // “2” would also have worked // !) (result: a 121 meter block)
    As expected.

#5

Thank you for your detailed reply.
Your steps are exactly what I would use in normal sketchup.
Alas they do not work in my.sketchup.com under the latest google chrome in
linux. Also not in firefox as I have just determined.
All goes well until I type “m” on the keyboard. Once I hit “m” my.sketchup
says "Mark scroll position (press a key…)"
There is one difference between FIrefox and Chrome: On typing these numbers
firefox displays the numbers. It won’t do a thing with them, but I see what
I type. Until the “m”. Then everything is over.
Thanks again for the effort.


#6

I can not. I fail at the same point. The moment I type an “m” for meters it
wants to set a “Mark”.


#7

You spotted a typo. Thank you.
I actually did put in 2m. The phenomenon continues since my.sketchup.com does not react to numerical input for me. Never mind the actual numbers. I seem to be unable to go past the “m” in, for example, “2m”.


#8

I did that on a Windows 10 but just repeated exactly the same (except
pressing

to get “Push Pull” tool) in Chrome on Linux Ubuntu 16.04 all
updated…
Strange…


#9

Maybe due to locale keyboards setting…


#10

You do have to start dragging one of the handles to be able to do the scaling by inputting values into the box (do not click the box!). Use decimal point " . " and to separate Red, Green , Blue axis dimensions use a " , " comma (not a semicolon " ; " as in the SketchUp program).


#11

I always use en us.

MikeWayzovski Regular
May 15

Maybe due to locale keyboards setting…


Visit Topic or reply to this email to respond.


In Reply To
knurd75
May 15
You spotted a typo. Thank you. I actually did put in 2m. The phenomenon
continues since my.sketchup.com does not react to numerical input for me.
Never mind the actual numbers. I seem to be unable to go past the “m” in,
for example, “2m”.


#12

I do start with dragging the handles. I do not click the Box. I fail at the
"m" for meter. Lets stick with scaling for the time. No commas there. Just
"10m" for example. I fail at the “m”


#13

And if you just type <2> and then hit
(With a ‘Template’ of the Metric meter kind?)
How about “2000mm” does that fail too?
Have you been playing with keybindings in Linux? I know they exist but am not very knowledgeable about how or what to do about them. My Ubuntu is pure vanilla.


#14

Just checking @gregor_shapiro you know this is my.sketchup not normal sketchup don’t you? I’m not sure and I don’t mean to be patronizing, but it had me confused.


#15

is a VimFx notification…

You can temporarily disable VimFx by using Ignore mode. Press i to enter it, and shift-escape to exit. Use the blacklist to automatically enter Ignore mode on specific sites.

john


#16

Sorry if I’ve missed this… what kind of keyboard are you using?

john
.


#17

Thank you very much for the time and effort.
If i type 2 and enter like you suggested using the metric norm it just
confirms the rectangle as seen on screen.
If I try 2000mm it does the following once I hit the first m: “Mark scroll
position (press any key…)” It does that whenever I press m, no matter
what key I pressed before m.
The linux side.
I have my windowmanager configured with all keybindings out of the way.
Whatever Software is running has all the keyboard for itself. Only
exception ist left alt + esc. That puts me in a special mode to enter
further keycommands. I usually have no collissions betweeen software and
windowmanager. (i3wm)
Many thanks again. I appreciate all your help.


#18

So then it’s your browser that “has all the keyboard for itself.” Maybe you should take a look at the browser.


#19

That could be very much the problem! I will check immediately.

Yes! That was it!
Thank you very much. I blacklisted my.sketchup.com in vimfx in firefox
and everything works as planned.
I guess in chrome vimium makes the same problems.

Yes it does. I blacklisted the keyboard input for vimium and away we go!
Thanks again. It was my bad, but I love me those vim shortcuts. Something I
will look out for as a source of keyboard problems in advanced web-apps.

I hope somebody will find my problem and the working solution helpful.


#20

I am using a logitec k400r. But the problem were the browser addons vimium
in chrome and vimfx in firefox. The hijacked the keypress “m” and tried to
set a scroll mark. Something I never used before. my.sketchup.com is
blameless and works a treat after I disabled these plugins for
my.sketchup.com
Thank you for the help!