Inability to use measurement box

As a newcomer I am probably being dumb but I cannot make the measurement bar work. I start a rectangle, type in say 3m,2m then press enter but it doesnt work. Any help please

Are you clicking in the box before typing? If so, don’t! Just type and it will get your values. Because so many other UI’s require a click to select an input, this is a frequent stumbling block for SketchUp newbies.

1 Like

Try using 3m ; 2m instead of using the comma as field separator.
(Your keyboard is set to non US).

1 Like

Thanks.I was clicking there first, but now even without clicking I grt no response. I even try with swithing keyboard between EN and Spanish. No go!

Thanks. Tried both English and Spanish keyboard on two computers. Tried using colon and semi colon / no go

@pedro
It’s not so much the keyboard settings, but the ‘locale’ used when SketchUp was installed.
Type or copy+paste + [enter] this in the Ruby Console:

Sketchup.get_locale.upcase

If it’s an EN-US or similar locale you use a ‘.’ as the decimal separator and a ‘,’ as the files separator thus::

12.3,45

or if you want to use units other that the model’s current units settings:

12.3m,45m

Remember NOT to click in the Measurements box, just type what you desire…
And remember to press Enter when you are done with the input.

BUT, if you have a ‘European’ type of locale then you might have the decimal separator set as a ‘,’ and the field separator then becomes a ‘;’, so it’s now:

12,3;45

or

12,3m;45m

Does that help ?

1 Like

Thanks.I was clicking there first, but now even without clicking I grt no response. I even try with swithing keyboard between EN and Spanish. No go!

Thanks. I will try that

You NEVER need to click on the Measurement box.
In fact clicking on if will break the tool’s train-of-thought !
When you are inside any tool which can accept typed input, then you just type it…
It then appears in the Measurement box.
Remember to press Enter to tell SketchUp when you have done with your values’ inputting…

Thanks a bunch - all working now!
De: TIG no-reply@sketchup.com
Para: pedroec1@yahoo.es
Enviado: Sábado 12 de septiembre de 2015 23:22
Asunto: [SketchUp Forum] [SketchUp/Feature Requests] Inability to use measurement box

| | TIG SketchUp Sage
September 12 |
| @pedro
It’s not so much the keyboard settings, but the ‘locale’ used when SketchUp was installed.
Type or copy+paste + [enter] this in the Ruby Console:Sketchup.get_locale.upcaseIf it’s an EN-US or similar locale you use a ‘.’ as the decimal separator and a ‘,’ as the files separator thus::12.3,45or if you want to use units other that the model’s current units settings:12.3m,45mRemember NOT to click in the Measurements box, just type what you desire…
And remember to press Enter when you are done with the input.BUT, if you have a ‘European’ type of locale then you might have the decimal separator set as a ‘,’ and the field separator then becomes a ‘;’, so it’s now:12,3;45or12,3m;45mDoes that help ? |

To respond, reply to this email or visit Inability to use measurement box in your browser.

I just downloaded the latest version of Sketch up Make 2016 and now can’t see a measurement box???

Please don’t make multiple posts on the same topic. It makes for confusion.