Sketchup not accepting numerical input

When trying to type in a measurement, sketchup will not accept the input. I will register commas, periods, or any other deliminator, but wont recognize the actual number. steps to reproduce:

  1. select a line
  2. click and release on the origin
  3. type a number
  4. hit enter

I have tried this with my number pad and top number row on both my laptop and my external keyboard. it simply won’t accept the number input. I have also tried to click the origin, then click the end point (though I recognize this is not how it is supposed to be done according to the forums I have seen)
I have also tried turning on and off the SNAP-TO feature, with no results
please help!

After clicking and releasing to set the first end, you need to move the cursor in the desired direction before you enter the length.

Here I clicked and released to set the first point, moved the cursor in the desired direction, let go of the mouse without clicking again, and typed the length followed by hitting Enter.

Dave I appreciate the quick response! I have done this as well. I want the line to be 40" along the red axis, so I will set the origin, move the cursor fairly close to the 40" needed, making sure the line is still red, then I will try to enter a number, but it still does not accept it.

In response to your video Dave, that looks exactly like the procedure I am trying to follow, set the origin, move in the desired direction, then enter a number. I am NOT clicking to set the endpoint, and in fact the measurement box will accept input, but it is only the deliminators, commas, periods, etc.

It sounds as if NUM lock is off? , but that wouldn’t stop the top row of numbers working usually.

What browser are you using?

Num lock is on, I am using chrome

Hmm, I’m using Chrome fine at the moment.

I would imagine chrome to be fine, haha that is why this is driving me crazy

Go to the Chrome menu, then Help submenu, and choose the About Chrome page. Chrome should check for an update. Does it update to a newer version ?

I have almost the same problem. I’ve been using Sketchup for ages and now trying to get rid of my laptop and use my phone instead. (Huawei P20 with Android 9.1) It is connected to a monitor using USB-c -> HDMI in Huaweis desktop mode. I use a wireless keyboard and it works great everywhere. I can input the numbers just fine, but somehow, it seems like sketchup web simply won´t register the enter key. (I have tried several browsers, like Chrome and Opera)

Silly me… I realized that in desktop sketchup for windows, sketchup uses localization so I get comma for decimals and semicolon for separator, just like we use in Sweden. On the web, it’s seems like it’s dot for decimals and comma for separator. Hehe… “Enter” key was in fact recognized, but the numerical input was wrong. Oh well, no biggie and definitely no need to fix. It works just fine using comma for separator instead of semicolon.

1 Like

This topic was automatically closed after 91 days. New replies are no longer allowed.