Twinmotion

Has anyone tried using Twinmotion since moving to SKU 2024? I used it a few years ago, but abandoned it when no clients wanted to pay for my extra time to use it for my designs. Thought I’d give it another whirl. The interface seems to have changed significantly, and the tutorials I can find seem out of date. I can naviagte to my SKU models but not open anything. I’ve installed the plugin, but can’t see what it does, and again no tutorials up to date on what I need to do to export something useful. Any advice or signposts to recent guides?

1 Like

Ignore the plug-in, it’s not yet updated for 24 (unless you are still on 23 as your profile says, the plug-in works in 23 but I prefer a workflow without it anyway). TM can import .skp files. Start TM and navigate to import, then simply import the .skp you want to render from its location on your HD. If you need to update geometry alter the SketchUp file and save it, then update the reference from within TM, similar to how you work with Layout.

Yes the TM interface has changed a bit, I think much for the better. It’s streamlined and much easier to manage the menus and options in the new format.

1 Like

+1 on the plugin opinion.

I’ve had some problems with 23 as well, materials synchronised at a super small scale for instance, and resetting for no reason (some materials would, other wouldn’t).
Apparently there is a brand new one, 5.4.1 working with SU24 and TW24.1
Haven’t tried it yet, I’ll have to (quite soon) ahead of a training session.

But know that importing + updating works fine. I just imported a SU24 file in TW24 minutes ago, worked fine. so you can work without the datasmith.


The interface changed in 2023, on the official forum there was a video showing step by step the changes, it’s this one

Look for tutorials / articles / medias using twinmotion 2023.1 and later, they should all have the new interface, and they’re still relevant for TW24

2 Likes


When I navigate to my files, TM doesn’t seem able to open any SKP documents. Do I need to export them to special file format first? When I’ve tried the plugin, it produces a folder with tons of files but they can’t be opened in TM either?

Thanks, I hadn’t found that, so will take a look.

uhh, from the interface, it looks like you didn’t download Twinmotion but Unreal Engine, the game / movie render that Twinmotion uses.

in the epic store, you go (on the left side) to Unreal page, and then on the top, you pick twinmotion. and install twinmotion. no need to install unreal engine unless you’re making a video game or some very advanced stuff

1 Like

Thanks, that makes more sense now!

1 Like

@ateliernab I was having issues today with getting TM24 to refresh a SU24 file after I made a few changes to the model in SU after selecting all my materials and lighting in TM. I couldn’t get the model to refresh is there another command I’m missing? I saved in SU and hit the refresh multiple times and it didn’t import the adjusted file after a load screen.

When I tried to re-import the file of course it didn’t have all my textures and materials I had alrady selected. Any ideas? Thank you in advance!!

ugh. Somehow I really hope that’s only your file acting up :smiley: :smiley: but I’m too pessimist to really think it is.

I’ll check this afternoon to see if the synchronisation with 24 and 23 works as it did, and if not, I’ll have to try the datasmith I guess…

I’ll come back to you.

Oh, well actually I’m using 23 TM and 24 SU maybe that’s the problem. I downloaded the newest datasmith but that wasn’t working. Will be messing with it now so will report back if I find a solve before you get back. Thank you!!

Refreshing the model is working for me in TM23 and SU24 (I haven’t loaded TM24 yet). Just to be sure, you are using this button here? And nothing happens?

Interesting. Even if I reimport the same file over again, the material substitutions I have made in TM persist relative to the material choices in SU.

6

If you change a material in SU then updating or reimporting into TM will overwrite the existing TM material. I think of them as 1:1 parings, TM maps over a given material or object (depending on how you have the material applicator set in TM). But the relationships remains, if you apply a material in SU that already has a corresponding TM material assigned to it it will show as the selected material in TM without re-applying.
7

Thanks for sending this over. It’s so stupid but I think the issue was the source file was in my google drive folder that wasn’t syncing. Once I re-did the file and saved on my actual hard drive I didn’t run into any issue with materials. I am now having issues with datasmith saying there’s no connection between the two but I can just refresh and that works.

1 Like