Turn off new toggles

It looks like the stupid copy-move ‘feature’ is being fixed already, just wanted to add my voice of annoyance, it entirely breaks the workflow, like others have mentioned. This totally should be a Preference setting, please and thanks =)

4 Likes

I’m so happy to find this post ! Working with Sketchup everyday since almost 20 yers, I was struggling like a beginner since a few day, just after the update, without understanding why… And now I know ! I tried to get use to it, but, it’s not as efficient as the previous way of doing things, especially the material picker, terrible.

When you do such important changes on a software workflow, you must put somewhere a small option to disable it. It’s such a small and easy thing to do, just a tick box in parameters "use SU classic tools or “new ones” ".

I hope it will be done…

6 Likes

Just making sure this thread doesn’t disappear in to the void.
I’m still finding them fantastically annoying and a hindrance to my workflow.

2 Likes

Just assuring this is not lost in the void :+1:

7 Likes

Same here. the sticky toggles are messing me up.

I tried to get used to it, but it’s way too easy to make copies on accident.

Looks like a fix is on it’s way… hopefully soon!

Also agree that these types of ‘feature’ changes must always have a way to turn them off or revert to the original. You could add a new tab in preferences called “Annoyances”

3 Likes

Woohoo!

This should (at least in theory) allow people to use both the old hold pattern that some have used for 20 years and the new toggle pattern.

If you still (we hope not) experience issues with the modifier keys, feel free to inform us so we can do our best to make it better.

3 Likes

@ene_su
I’ve had a quick play this morning and so far so good, the move tool is vastly better.
There’s still a bit of strangeness to the paint bucket/material sampler but I think this might be just me ‘trying’ to find a difference rather than it actually being different to pre 2021.

Thanks to all that chimed in on this.

1 Like

Much better here thanks. The paint bucket sampler still seems to be sticking on intermittently when I hold Alt down when sampling though.

2 Likes

I see people praising the new update, but I’m still wondering if there’s a toggle switch to turn off the new modifiers. Or are we still waiting for this?

So far the recent update fixed all my problems except the paint bucket/sampler, having said that I still would have liked the option/pref to turn them fully off like they were before…… not that we’re ever going to see it.

In theory no such toggle should be needed. The old behavior should be restored with the new behavior also existing side by side. Both holding a modifier key and tapping to toggle the state should be possible in all tools you could previously hold in. Copy now also ends once you put down the object.

Are you still experiencing any issues with modifier keys?

1 Like

I figured out the problem. Someone hacked my computer and deleted the updated version of SU.
(Read: I forgot to install the update.)

@ene_su I’ll see if I can record a video of the sampler in action but for me it’s definitely ’sticking’, not all the time but around 50%+ of the times I use it.

My usual sequence is to press B, hold SHIFT, click on the surface I want to sample, release SHIFT (return to bucket) and then click on the surface(s) I want to paint but….
When I release SHIFT the sampler remains active and clicking on the target surface results in sampling that instead of painting it.

If I go slowly and watch the cursor I can see that the sampler is still active after I release SHIFT and single pressing SHIFT will ‘toggle’ it back to paint.

I’m guessing the bit where I ‘hold’ SHIFT is the key part but that’s the way I’ve always done it prior to the toggles being initially introduced.

Any chance you have turned on sticky keys in windows, it’s a setting that is offered if it thinks you are doing lots of double tapping.

I struggle to reproduce this. Do you have the latest version of SketchUp?

@box as I was writing my post above I was thinking the same thing, I’ll check when I’m in the office later.

@ene_su yea, I’m upto date on everything related (Windows, drivers, apps etc) I’ll check Box’s suggestion and record a video if necessary.

And there is a ******* keyboard shortcut to turn it on. I don’t remember what it is but I have several times hit it by mistake.

5 shifts.
image

@ene_su
Opps, in my post above I said I held the Shift key drown, I meant the ALT key to get the sampler, sorry if that confused.

Did some more testing…
I don’t have sticky keys on in windows 10 so it’s not that.
I made a simple model of just some coloured squares and repeatedly sampled them and COULDNT get the sampler to stick but……
I then tried with one of my heavy models (200Mb +) with lots of material with large texture maps an I COULD get it to stick on the sampler about 50% of the time when sampling them.
Repeatedly sampling the same 3 or 4 materials will initially cause the sticking but then it works as expected but ….
performing several non material related actions (copy/draw/move etc) and then a sample ([B],[ALT][CLICK]) of a heavy material will almost always cause it to stick.

I wasn’t able to do a screen recording as I don’t have anything suitable installed. Any suggestions?

@Mark, we may have a bug with large models. I haven’t tested myself, but my suspicion is that lag (even subtle lag) could interfere with the timing and feedback.

Could you look into or delegate this?