Turn off new toggles

Is there any way to turn off the new toggle options? they are really messing up my workflow.

Thanks!

6 Likes

The old way was that I would toggle it on and, when used once, would turn off. I really really hate the new way because the tool stays on after I use it once. If i could turn this feature off it would be great. Do you know if there is a preference where I can stop the toggle?

1 Like

Can you say a bit more about where you find yourself getting hung up while modeling? Which tools are you suing when you are tripped up by the toggle behavior? Thanks for clarifying!

Yes,

My typical workflow for copying an item looks like this:

Select move tool >
Tap (not hold) modifier key >
Move/copy the item

At this point im fully expecting the modifier key to be inactive but now it stays active and my next move inadvertently copies the object i was just moving.

The reason I like to tap and not hold for this modifier is because i usually have some kind of calculation involved in the move copy so I will tap, type in my number (distance for an array usually) and move on. but now i am getting weird behavior. I just want to be able to have the option to disable the toggle feature.

8 Likes

1000000% need to know if there is an option to turn off new toggles. I am so used to holding the CTRL while copying an object and now I have to be extra careful not to duplicate objects and not even know it.

6 Likes

I’d also like the ability to turn off the new sticky toggles, I’ve tried to like them but like others above it’s massively screwing with my flow, I think they are a good idea for beginners but for us that know what we’re doing they are a bit like Clippy form MS office circa 2000.
Additionally they are over zealously applied to some tools; when I sample the material (Alt Paint bucket) of one surface and apply that material to another surface the sampler ‘sticks’ and instead of applying the picked material it samples the 2nd surface …… that’s just dumb.

Sticky toggles have definitely slowed me down and made SU somewhat frustrating …… sorry.

5 Likes

I absolutely don’t know why these sticky commands have been added. Who has asked for them???

I can understand that, this might be annoying at first since it changes up a workflow that may have been a place in long for time. And if the SketchUp team could implement an option to toggle it that would be best from a user perspective.

However the changes are really nice for user like me that use a Space Pilot 3D mouse. It’s way more forgiving on my hands when you can just tap the modifier key instead of needing to hold it down. But overall i think the consistency across tools are gona be a good improvement in the long run, especially for new users.

1 Like

Not for me Teem! It’s pretty annoying and I hope they will put a switch in it to turn it off. :frowning:

2 Likes

That’s what I hoped but they’ve been annoying at 2nd, 3rd 4th etc.
I’m not being reactionary, I really have tried to like/use them but after a couple of weeks of use they are very noticeably slowing me down. I don’t want them gone just an option to turn them off.

3 Likes

@Mark Earlier in this conversation you’d commented and I’d like to ask if there’s a possibility that the tool toggling will become an optional setting?
It’s really throwing me off my game as I now have to constantly check if I’m moving/copying etc. whereas before I ‘knew’ what I was doing as I was either physically holding a key down or not.
The previously mentioned paint bucket being sticky is really driving me mad and if nothing else happens that MUST be fixed.

2 Likes

For sure add the ability to turn off (I don’t have a strong view) but this new feature whether it is good for beginners or not as you say, but great also for us advanced users too :wink:

1 Like

The one me that bugs me the most is that the standard keyboard shortcut for undo toggles the eraser tool to soften mode. I quite often accidentally erase something more than what I wanted, and it requires attention and extra time to notice and reset the mode.

The other one I keep tripping over is move tool copy mode. When I need to move a copy of a component to a distance past the far side of the original, my brain is trained to the workflow of moving it past, grabbing the near side, and moving back to the required place. Due to copy mode lock, I get an extra that I have to delete.

7 Likes

When I’m erasing lines on my model, I often find myself struggling as now when I orbit and pan using the shift key, it simultaneously toggles the eraser mode. I don’t know if this is an issue, or something I just need to work around and change my method.

Yes this is happening to me way more often than I thought would happen. It’s been a bit frustrating, and I thought it was my orbiting and panning, but it’s also the command key in undo changing the eraser state. Hrmm…

Just want to provide a quick update that we are definitely working on both the mode switching states for shortcuts and Undo (for Mac users) and also the undesirable persistence of toggle state for Move/Copy. We’ve already met with a few forum posters to clarify the sticking points of the 2021.1 release, but if you’d like to provide early feedback on how we are addressing the concerns in this thread, please send me a DM!

3 Likes

As soon as I can get a bit of time I’m rolling back to the previous version, I’ve tried, I really have but this new ‘feature’ is a hindrance not a help.
I’ve turned the air blue today with the frustration that these toggles have caused me.
I’m tired of erasing unwanted copies when all I wanted to do was move and I’m tired of undoing a move when I wanted a copy.
Keep it by all means but PLEASE give us the option to turn the ■■■■ thing off.

5 Likes

Yes Yes Yes. The copy option is messing me up. I move an object then move it again to a correct offset but instead of moving it is copying.

3 Likes

The toggle to lock Move into Copy etc should be an option set up in Preferences.
It was a poorly thought out change to make it a fixed thing - although new users might appreciate it [might?] I suspect that most existing users find it APITA !

9 Likes