Option Move Copy changed ( for the worse ) in SU Pro2021

After moving onto Sketchup Prop 20121 Version 21.1.331 ( Mac OSX Mojave ) in notice the create copy when using the move tool behaves differently to all previous versions ( which is hard to get used to ). In all previous versions when you held down the option key and moved the item, the original item remained in place and a copy was dragged to the new location. In version 2021 this no longer works that way, and a copy is only made when you option after you commence moving, and that drops the original back in place. Its a bit off putting as you watch the item you want to be retained in place move and then be dropped back after you then hit option. Is there a preference or way to set it back how it was. Just cant get used to it after so many years of a clear method of hold option then drag a copy.

It’s a toggle, so if you tap it rather than hold it it works.
Double tap before you start will allow the new stamp action to activate which will place a copy wherever you click until you stop.

Thanks Box, Yes just tried that and thats how it works, cant say i like it, don’t know what was wrong with the way its been for years previously. Guess one has to get used to it.

In this case you do. For a couple of other tools the behavior was changed to allow for the old way or the new way, you could either hold or tap the modifier key. But even if Move tool is altered to allow for that, it wouldn’t help you, because those changes go into SketchUp 2022, and would not be added to a 2021 update.

Fwiw, it has always been a toggle, no need for holding on the modifier key in versions prior to 2021.
As SketchUp is evolving more rapidly these days, other features or ‘bugs’ tend to show up upon new releases, despite testing all sorts of using the software.
Patches or minor updates will be a common thing.


Although it did work as a toggle, it would only do that for one copy. Holding down the modifier let you do repeated copies.

1 Like

This isn’t working for me at all, and I just noticed it. Whenever I use Copy, whether tapping Ctrl or holding Ctrl, the tool reverts to its default Move function after copying anything only once. How do I get the Move tool to stay on Copy until I manually change it?

Hit Ctrl (option Mac) twice to enter stamp mode. However it will revert to normal Move each time you change tools and return to Move.

I understand how it works but it seems like a bug because up until recently it would stay on Copy even when switching between tools.

That makes no sense, changing tools ends the previous operation, with the exception of orbit/pan/zoom via the middle mouse.

I just preferred it as it was in 2020, so long as you held down option and dragged you got a copy. Now with the move tool, no option no copy, click option get one copy upon move, click option 2 times you get repeating stamps. But theres no easily shown cue at the cursor to show which of these modes you got, and I frequently find I end up not copying when I want to. Probably holding the option key down by habit. As it worked out the old way holding down option did both modes effectively. ie if you held option down and dragged and dragged again you got repeats as many times as you dragged so the similar to the stamp mode. Will get used to it I guess.

The little cross and stamp icons get added to the cursor depending on what it is doing.

1 Like


Thanks Box, your right, I never saw that, its so small my poor eyes hardly can see. But thats a good tip. Better get some higher power glasses. Thanks for the little video, very decent of you to demonstrate.

Yes, it could certainly be bigger, the young’ns who design these things don’t know what it is like to be old.


This is one reason that I have my cursor size set to about 150%! High resolution monitors think that everything should be as tiny as possible!

1 Like

Interesting. I never really looked at that.