Trying to download sketchup


#1

Hey everyone i have been trying to download sketchup 17 on my Dell laptop with windows 10 and haven’t had any luck yet! This thing has been downloading for 6 hours and I was wondering if this is normal? Thanks


#2

No. It shouldn’t take six hours unless maybe you have a dialup connection. Can you see what the download speed is?


#3

I get this over and over

it will fill the box all the way and start over


#4

No I do not have a clue how to check download speed


#5

Sorry it downloads fast it’s the setup I can’t get through


#6

So it’s the installation that is hanging up, not the download? Are you right clicking on the SketchUp installer file and choosing Run as administrator? If not, do that.


#7

Google “Speedtest.net” there is an online speed checker you can use
You’re connection will affect install speed as it downloads from internet at the same time ( I think)


#8

Ok I am trying that now


#9

Yes make sure you **run as administrator ** sorry to butt in @DaveR !


#10

How many times should I see this? It has done loaded 100% 1 time and now it’s loading again and I am in administrative mode


#11

Did you right click and choose Run as administrator?

The message indicates the installer thinks .NET Framework needs to be update. Go to the Microsoft site, get and install .NET Framework 4.5.2


#12

In my experience it takes 3-5 min to install the program to give you an idea. It’s very fast. The installer is adding missing dependencies to you system to make sketchup work but it shouldn’t take more than a few minutes.


#13

And it can do that unless you use Run as administrator.


#14

Yes @DaveR you’re right, he said he ran as admin with the last picture but still the same, it doesn’t seem successful for some reason?

@Eddieb378 make sure you right click the sketchup installer icon and run as admin like Dave said he is right


#15

No. He said he’s in “administrative mode.” That could mean he logged in as administrator which is different than starting the installer with Run as administrator.


#16

Yes I see look above I edited, he needs to do above on last post!


#17

Yes I ran as administrator


#18

When I right click the download I select the run as administrator option right below open


#19

And you have the same result from this?


#20

Yes same result it’s killing me