Sketchup download trouble


#1

So i recently got a new computer at work and i went to download sketchup onto it and it wont let me. I keep getting error messages and the install stops, how do i get it on my computer?


#2

What’s the error message?


#3

Where are you downloading it from, what version of SketchUp, what is the error message?


#4

Ive tried all the versions that i could find downloads for and ive gotten the same message each time. It says “Sketchup make year here setup wizard ended prematurely because of an error. Your system hasnt been modified. To install at a later time run setup wizard again.” I run it again and the same message comes up. And ive been using the download links that are in one of the posts on the forum here, both 32 and 64 bit versions, same result.


#5

Try here. It’s the official SketchUp download page.


#6

Yeah i went there at first and it never gave me a download link, it kept asking me to buy sketchup pro or go buy a student link and im not wanting to do all that.


#7

You can bypass that here: https://www.sketchup.com/download/all


#8

Just tried those and i get that same error message. Im starting to think i just cant get it on this new computer for whatever reason.


#9

Are you really still using Windows 7 on “this new computer”?


#10

No i never said it had windows 7, it has windows 10.


#11

Your profile indicates you have Windows 7. That’s the only information we were given about your operating system.
Screenshot%20-%201_2_2019%20%2C%203_13_36%20PM


#12

Oh. Well i have windows 10 pro now with a 64 bit operating system and processor, 16 GB of ram and currently 158GB of free memory so i would assume i have the sufficient qualifications needed to run the program, especially since the computer that i had it on was alot older.


#13

How about updating your profile, then?

So you’ve downloaded SketchUp 2017 Make, correct? And exactly what steps are you taking to attempt to install it?


#14

Yes i downloaded sketchup make 2017. Ill hit download and the .exe file downloads to my computer, after it finishes i click on it and the sketchup make box comes up extracting the installer, the installer starts saying welcome to sketchup make 2017 click next to continue so i click next, then it asks me the file location, it goes to me C drive and i click the next button again, then i get the error box of the setup wizard ending prematurely.


#15

The correct way to install it is to right click on the downloaded exe file and choose Run as administrator from the context menu. You need to do this under your normal log in to Windows.


#16

I just tried that and i still get the same dialogue boxes and the same error box at the end of it all.


#17

And ive never had to do that for any other program and weve installed alot of programs and this is the only one giving me issues.


#18

There’s plenty of threads here that talk about why Run as administrator is required for proper installation. I wouldn’t have brought that up if I wasn’t trying to help you get SketchUp installed.

Going back to read through the thread…Have you tried installing SketchUp 2018 Pro? You say you are installing it at work which would imply you need to be using Pro. Also, have you checked to see that your company’s firewall isn’t preventing a connection to Trimble’s servers which is also required for correct installation?


#19

Oh yeah i wasnt doubting you, just saying weve never had to do it. I have tried 2018 with the same result. I am installing at work but it isnt required for work, i just like to draw personal custom plans on it. And from what i can see there is no block on Trimble.


#20

Check out point #5 of Ty’s post here. It sounds like the issue that you are seeing…